aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2007-09-18 19:55:40 +0800
committerdinoex <dinoex@FreeBSD.org>2007-09-18 19:55:40 +0800
commitfffe639aff3b051a7fc8212e2cd433ab5a858e15 (patch)
treea2fa439d0c7c46b3b5f62381a7d1e1463b228256 /graphics
parent6b23e68036d055a710928c3a98c9957714648f80 (diff)
downloadfreebsd-ports-gnome-fffe639aff3b051a7fc8212e2cd433ab5a858e15.tar.gz
freebsd-ports-gnome-fffe639aff3b051a7fc8212e2cd433ab5a858e15.tar.zst
freebsd-ports-gnome-fffe639aff3b051a7fc8212e2cd433ab5a858e15.zip
- bugfix for freetype
Submitted by: Jung-uk Kim Obtained from: graphviz-CVS
Diffstat (limited to 'graphics')
-rw-r--r--graphics/graphviz/Makefile1
-rw-r--r--graphics/graphviz/files/patch-gvtextlayout_gd.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index e3221cbc95ac..ba6535830625 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -7,6 +7,7 @@
PORTNAME= graphviz
PORTVERSION= 2.14.1
+PORTREVISION= 1
CATEGORIES= graphics tk84
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
diff --git a/graphics/graphviz/files/patch-gvtextlayout_gd.c b/graphics/graphviz/files/patch-gvtextlayout_gd.c
new file mode 100644
index 000000000000..0afaba234ecd
--- /dev/null
+++ b/graphics/graphviz/files/patch-gvtextlayout_gd.c
@@ -0,0 +1,20 @@
+--- plugin/gd/gvtextlayout_gd.c.orig 2007-07-20 14:38:03.000000000 -0400
++++ plugin/gd/gvtextlayout_gd.c 2007-09-12 13:20:12.000000000 -0400
+@@ -26,7 +26,7 @@
+ #ifdef HAVE_LIBGD
+ #include "gd.h"
+
+-#if defined(HAVE_LIBGD) && defined(HAVE_LIBFREETYPE) && defined(HAVE_GD_FREETYPE)
++#if defined(HAVE_LIBGD) && defined(HAVE_GD_FREETYPE)
+
+ /* fontsize at which text is omitted entirely */
+ #define FONTSIZE_MUCH_TOO_SMALL 0.15
+@@ -172,7 +172,7 @@
+ #endif
+
+ gvplugin_installed_t gvtextlayout_gd_types[] = {
+-#if defined(HAVE_LIBGD) && defined(HAVE_LIBFREETYPE) && defined(HAVE_GD_FREETYPE)
++#if defined(HAVE_LIBGD) && defined(HAVE_GD_FREETYPE)
+ {0, "textlayout", 2, &gd_textlayout_engine, NULL},
+ #endif
+ {0, NULL, 0, NULL, NULL}