aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-10-01 03:24:30 +0800
committertijl <tijl@FreeBSD.org>2016-10-01 03:24:30 +0800
commitf493fce6a3261de0136fe170a7b704c4fe236b88 (patch)
tree8b44219153a720f367633c8fe248933750735b7d /graphics
parent70cc79c60e2f5a9e208b1727c67b6fe406e80c61 (diff)
downloadfreebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.tar.gz
freebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.tar.zst
freebsd-ports-gnome-f493fce6a3261de0136fe170a7b704c4fe236b88.zip
Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.
USES=localbase:ldflags can be used to set LDFLAGS. Normally LDFLAGS appears too early on the command line causing some ports to link with their own libraries in LOCALBASE (if installed) instead of WRKSRC. Also make use of _USES_POST so -L${LOCALBASE}/lib is added as late as possible after anything a port Makefile might set. Use _USES_POST instead of .include in libedit.mk and libarchive.mk so things like 'USES=libedit localbase:ldflags' work correctly. Fix some issues with LIBS in some ports. Switch ports that don't support LIBS to localbase:ldflags. PR: 212987 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/bmeps/Makefile2
-rw-r--r--graphics/dcp2icc/Makefile2
-rw-r--r--graphics/dcraw/Makefile7
-rw-r--r--graphics/lcms/Makefile2
-rw-r--r--graphics/lcms2/Makefile2
-rw-r--r--graphics/libprojectm/Makefile2
-rw-r--r--graphics/pngrewrite/Makefile4
-rw-r--r--graphics/poppler/files/patch-configure36
-rw-r--r--graphics/py-ming/Makefile2
9 files changed, 39 insertions, 20 deletions
diff --git a/graphics/bmeps/Makefile b/graphics/bmeps/Makefile
index 467e7bc5deac..2b786815a6b4 100644
--- a/graphics/bmeps/Makefile
+++ b/graphics/bmeps/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= ac_cv_header_sys_termios_h=no \
ac_cv_header_db_h=no
ALL_TARGET= bmpp
-USES= gmake jpeg localbase
+USES= gmake jpeg localbase:ldflags
PLIST_FILES= bin/bmpp
diff --git a/graphics/dcp2icc/Makefile b/graphics/dcp2icc/Makefile
index 260bac60ecdd..3ec4bab5efd0 100644
--- a/graphics/dcp2icc/Makefile
+++ b/graphics/dcp2icc/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libexpat.so:textproc/expat2 \
liblcms.so:graphics/lcms
-USES= localbase scons tar:bzip2
+USES= localbase:ldflags scons tar:bzip2
USE_GCC= any # segfaults on exit when built with Clang
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/dcraw/Makefile b/graphics/dcraw/Makefile
index c160c6282907..f136f9658f2c 100644
--- a/graphics/dcraw/Makefile
+++ b/graphics/dcraw/Makefile
@@ -12,15 +12,16 @@ COMMENT= Decoder for RAW files from digital cameras
LIB_DEPENDS= libjasper.so:graphics/jasper \
liblcms2.so:graphics/lcms2
-CFLAGS+= -I${LOCALBASE}/include/jasper
-LDFLAGS+= -ljasper -ljpeg -llcms2 -lm
+CPPFLAGS+= -I${LOCALBASE}/include/jasper
+LIBS+= -ljasper -ljpeg -llcms2 -lm
USES= jpeg localbase tar:xz
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
do-build:
- @cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
+ @cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CPPFLAGS} ${CFLAGS} \
+ ${PORTNAME}.c ${LDFLAGS} ${LIBS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
index 3eae5a63f1d2..931900104df9 100644
--- a/graphics/lcms/Makefile
+++ b/graphics/lcms/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
USE_LDCONFIG= yes
-USES= libtool localbase pathfix
+USES= libtool localbase:ldflags pathfix
PORTDOCS= *
diff --git a/graphics/lcms2/Makefile b/graphics/lcms2/Makefile
index 45a9eac525a0..209e79e6f136 100644
--- a/graphics/lcms2/Makefile
+++ b/graphics/lcms2/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
USE_LDCONFIG= yes
-USES= libtool localbase pathfix
+USES= libtool localbase:ldflags pathfix
PORTDOCS= *
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
index 1436d146dbb2..10d5b13904dc 100644
--- a/graphics/libprojectm/Makefile
+++ b/graphics/libprojectm/Makefile
@@ -15,7 +15,7 @@ LICENSE= LGPL21+
LIB_DEPENDS= libftgl.so:graphics/ftgl \
libfreetype.so:print/freetype2
-USES= cmake localbase
+USES= cmake localbase:ldflags
CMAKE_ARGS= -DUSE_OPENMP=OFF # openmp breaks build on 11.x
USE_GL= glew
USE_LDCONFIG= yes
diff --git a/graphics/pngrewrite/Makefile b/graphics/pngrewrite/Makefile
index 7f0d7504a214..2a8366f3be89 100644
--- a/graphics/pngrewrite/Makefile
+++ b/graphics/pngrewrite/Makefile
@@ -22,7 +22,9 @@ NO_WRKSUBDIR= yes
PLIST_FILES= bin/pngrewrite
do-build:
- ${CC} ${CFLAGS} ${LDFLAGS} -lm -lpng -lz -o ${WRKSRC}/pngrewrite ${WRKSRC}/libpngrewrite.c ${WRKSRC}/pngrewrite.c
+ ${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} ${LIBS} -lm -lpng -lz \
+ ${WRKSRC}/libpngrewrite.c ${WRKSRC}/pngrewrite.c \
+ -o ${WRKSRC}/pngrewrite
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pngrewrite ${STAGEDIR}${PREFIX}/bin/
diff --git a/graphics/poppler/files/patch-configure b/graphics/poppler/files/patch-configure
index 9b176321a8ef..97b51246cc25 100644
--- a/graphics/poppler/files/patch-configure
+++ b/graphics/poppler/files/patch-configure
@@ -1,13 +1,29 @@
---- configure.orig 2012-08-08 11:59:15.000000000 +0200
-+++ configure 2012-08-08 11:59:45.000000000 +0200
-@@ -20271,8 +20271,8 @@
+--- configure.orig 2016-07-24 22:14:28 UTC
++++ configure
+@@ -20556,7 +20556,7 @@ fi
- ac_save_USER_INCLUDES="$USER_INCLUDES"
- ac_save_USER_LDFLAGS="$USER_LDFLAGS"
-- USER_INCLUDES="$USER_INCLUDES $LIBJPEG_CFLAGS"
-- USER_LDFLAGS="$USER_LDFLAGS $LIBJPEG_CFLAGS"
-+ USER_INCLUDES="$USER_INCLUDES $LIBJPEG_CFLAGS $CPPFLAGS"
-+ USER_LDFLAGS="$USER_LDFLAGS $LIBJPEG_LDFLAGS $LDFLAGS"
+ ac_save_CPPFLAGS="$CPPFLAGS"
+ ac_save_CXXFLAGS="$CXXFLAGS"
+-ac_save_LIBS="$LDFLAGS"
++ac_save_LIBS="$LIBS"
+ CPPFLAGS="$CPPFLAGS $LIBTIFF_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $LIBTIFF_CFLAGS"
+ LIBS="$LIBS $LIBTIFF_LIBS"
+@@ -21387,7 +21387,7 @@ if ${ac_cv_lib_jpeg_6b+:} false; then :
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="$all_libraries $USER_LDFLAGS -ljpeg6b -lm"
++LIBS="$LIBS $USER_LDFLAGS -ljpeg6b -lm"
+ ac_save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $all_includes $USER_INCLUDES"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+@@ -21438,7 +21438,7 @@ if ${ac_cv_lib_jpeg_normal+:} false; the
+ else
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libjpeg6b" >&5
+ ac_save_LIBS="$LIBS"
+-LIBS="$all_libraries $USER_LDFLAGS -ljpeg -lm"
++LIBS="$LIBS $USER_LDFLAGS -ljpeg -lm"
+ ac_save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $all_includes $USER_INCLUDES"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index 117609ad8fd5..2190e9f64f8e 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ARGS= --enable-python
CONFIGURE_ENV= PYTHON_LDFLAGS="-L${PYTHON_LIBDIR} -l${PYTHON_VERSION}${PYTHON_ABIVER}"
GNU_CONFIGURE= yes
USE_PYTHON= autoplist concurrent distutils
-USES= autoreconf libtool localbase python
+USES= autoreconf libtool localbase:ldflags python
BUILD_WRKSRC= ${WRKSRC}/py_ext
INSTALL_WRKSRC= ${WRKSRC}/py_ext