aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-09-11 21:58:27 +0800
committerwg <wg@FreeBSD.org>2013-09-11 21:58:27 +0800
commit00687c5e7107d38f6fb0e1b09bf61a3db5338675 (patch)
treeae9d1605f3837845c49d67717fcc8a7522f1ca1a /graphics
parentbfb2a2a77f74620112ee493916d782d5b93a851a (diff)
downloadfreebsd-ports-gnome-00687c5e7107d38f6fb0e1b09bf61a3db5338675.tar.gz
freebsd-ports-gnome-00687c5e7107d38f6fb0e1b09bf61a3db5338675.tar.zst
freebsd-ports-gnome-00687c5e7107d38f6fb0e1b09bf61a3db5338675.zip
graphics/geos: update to 3.4.2
- Update to 3.4.2 [1] - Bump PORTREVISION for dependent ports - USES gmake - Use options helpers PR: ports/181422 [1] Submitted by: Rainer Hurling <rhurlin gwdg.de> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/geos/Makefile15
-rw-r--r--graphics/geos/distinfo4
-rw-r--r--graphics/geos/pkg-plist74
-rw-r--r--graphics/librasterlite/Makefile1
-rw-r--r--graphics/libreatlas/Makefile2
-rw-r--r--graphics/mapserver/Makefile2
-rw-r--r--graphics/qgis/Makefile2
7 files changed, 56 insertions, 44 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index 0179b35aa4dd..afd2eb4aa29f 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= geos
-PORTVERSION= 3.3.8
+PORTVERSION= 3.4.1
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/geos/
@@ -13,12 +13,14 @@ LICENSE= LGPL21
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
+USES= gmake
GNU_CONFIGURE= yes
OPTIONS_DEFINE= PHP PYTHON RUBY
+OPTIONS_SUB= yes
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHP} || ${PORT_OPTIONS:MPYTHON} || ${PORT_OPTIONS:MRUBY}
@@ -28,26 +30,17 @@ BUILD_DEPENDS+= swig1.3:${PORTSDIR}/devel/swig13
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
CONFIGURE_ARGS+= --enable-python
-PLIST_SUB+= WITH_PYTHON=""
-.else
-PLIST_SUB+= WITH_PYTHON="@comment "
.endif
.if ${PORT_OPTIONS:MPHP}
BUILD_DEPENDS+= ${LOCALBASE}/bin/php-config:${PORTSDIR}/lang/php5
CONFIGURE_ARGS+= --enable-php
-PLIST_SUB+= WITH_PHP=""
-.else
-PLIST_SUB+= WITH_PHP="@comment "
.endif
.if ${PORT_OPTIONS:MRUBY}
USE_RUBY= yes
CONFIGURE_ARGS+= --enable-ruby
CONFIGURE_ENV+= RUBY="${RUBY}"
-PLIST_SUB+= WITH_RUBY=""
-.else
-PLIST_SUB+= WITH_RUBY="@comment "
.endif
post-install:
diff --git a/graphics/geos/distinfo b/graphics/geos/distinfo
index d61f39a5890a..37a41880bf37 100644
--- a/graphics/geos/distinfo
+++ b/graphics/geos/distinfo
@@ -1,2 +1,2 @@
-SHA256 (geos-3.3.8.tar.bz2) = ebecd4d1a71bcc28e5e883296cd8c52a80d5596335e74728f320989734fa503b
-SIZE (geos-3.3.8.tar.bz2) = 1820064
+SHA256 (geos-3.4.1.tar.bz2) = d07ac375f3edd12425d6ce5a96db9739d5ff358cbdf60c6804f7a9e565af8ff2
+SIZE (geos-3.4.1.tar.bz2) = 1813303
diff --git a/graphics/geos/pkg-plist b/graphics/geos/pkg-plist
index bae8e2e76c7c..191a4504affa 100644
--- a/graphics/geos/pkg-plist
+++ b/graphics/geos/pkg-plist
@@ -4,25 +4,17 @@ include/geos/algorithm/Angle.h
include/geos/algorithm/BoundaryNodeRule.h
include/geos/algorithm/CGAlgorithms.h
include/geos/algorithm/CentralEndpointIntersector.h
+include/geos/algorithm/Centroid.h
include/geos/algorithm/CentroidArea.h
include/geos/algorithm/CentroidLine.h
include/geos/algorithm/CentroidPoint.h
include/geos/algorithm/ConvexHull.h
include/geos/algorithm/ConvexHull.inl
-include/geos/algorithm/ExtractLineByLocation.h
include/geos/algorithm/HCoordinate.h
include/geos/algorithm/InteriorPointArea.h
include/geos/algorithm/InteriorPointLine.h
include/geos/algorithm/InteriorPointPoint.h
-include/geos/algorithm/LengthIndexOfPoint.h
-include/geos/algorithm/LengthIndexedLine.h
-include/geos/algorithm/LengthLocationMap.h
include/geos/algorithm/LineIntersector.h
-include/geos/algorithm/LinearGeometryBuilder.h
-include/geos/algorithm/LinearIterator.h
-include/geos/algorithm/LinearLocation.h
-include/geos/algorithm/LocationIndexOfLine.h
-include/geos/algorithm/LocationIndexOfPoint.h
include/geos/algorithm/MCPointInRing.h
include/geos/algorithm/MinimumDiameter.h
include/geos/algorithm/NotRepresentableException.h
@@ -198,10 +190,21 @@ include/geos/io/WKTReader.h
include/geos/io/WKTReader.inl
include/geos/io/WKTWriter.h
include/geos/io/Writer.h
+include/geos/linearref/ExtractLineByLocation.h
+include/geos/linearref/LengthIndexOfPoint.h
+include/geos/linearref/LengthIndexedLine.h
+include/geos/linearref/LengthLocationMap.h
+include/geos/linearref/LinearGeometryBuilder.h
+include/geos/linearref/LinearIterator.h
+include/geos/linearref/LinearLocation.h
+include/geos/linearref/LocationIndexOfLine.h
+include/geos/linearref/LocationIndexOfPoint.h
+include/geos/linearref/LocationIndexedLine.h
include/geos/noding.h
include/geos/noding/BasicSegmentString.h
include/geos/noding/FastNodingValidator.h
include/geos/noding/FastSegmentSetIntersectionFinder.h
+include/geos/noding/GeometryNoder.h
include/geos/noding/IntersectionAdder.h
include/geos/noding/IntersectionFinderAdder.h
include/geos/noding/IteratedNoder.h
@@ -222,7 +225,6 @@ include/geos/noding/SegmentNodeList.h
include/geos/noding/SegmentPointComparator.h
include/geos/noding/SegmentSetMutualIntersector.h
include/geos/noding/SegmentString.h
-include/geos/noding/SegmentString.inl
include/geos/noding/SegmentStringUtil.h
include/geos/noding/SimpleNoder.h
include/geos/noding/SingleInteriorIntersectionFinder.h
@@ -245,6 +247,7 @@ include/geos/operation.h
include/geos/operation/GeometryGraphOperation.h
include/geos/operation/IsSimpleOp.h
include/geos/operation/buffer/BufferBuilder.h
+include/geos/operation/buffer/BufferInputLineSimplifier.h
include/geos/operation/buffer/BufferOp.h
include/geos/operation/buffer/BufferParameters.h
include/geos/operation/buffer/BufferSubgraph.h
@@ -322,12 +325,13 @@ include/geos/planargraph/NodeMap.h
include/geos/planargraph/PlanarGraph.h
include/geos/planargraph/Subgraph.h
include/geos/planargraph/algorithm/ConnectedSubgraphFinder.h
-include/geos/platform.h
include/geos/precision.h
include/geos/precision/CommonBits.h
include/geos/precision/CommonBitsOp.h
include/geos/precision/CommonBitsRemover.h
include/geos/precision/EnhancedPrecisionOp.h
+include/geos/precision/GeometryPrecisionReducer.h
+include/geos/precision/PrecisionReducerCoordinateOperation.h
include/geos/precision/SimpleGeometryPrecisionReducer.h
include/geos/profiler.h
include/geos/simplify/DouglasPeuckerLineSimplifier.h
@@ -340,6 +344,16 @@ include/geos/simplify/TaggedLinesSimplifier.h
include/geos/simplify/TopologyPreservingSimplifier.h
include/geos/spatialIndex.h
include/geos/timeval.h
+include/geos/triangulate/DelaunayTriangulationBuilder.h
+include/geos/triangulate/IncrementalDelaunayTriangulator.h
+include/geos/triangulate/quadedge/LastFoundQuadEdgeLocator.h
+include/geos/triangulate/quadedge/LocateFailureException.h
+include/geos/triangulate/quadedge/QuadEdge.h
+include/geos/triangulate/quadedge/QuadEdgeLocator.h
+include/geos/triangulate/quadedge/QuadEdgeSubdivision.h
+include/geos/triangulate/quadedge/TrianglePredicate.h
+include/geos/triangulate/quadedge/TriangleVisitor.h
+include/geos/triangulate/quadedge/Vertex.h
include/geos/unload.h
include/geos/util.h
include/geos/util/Assert.h
@@ -349,6 +363,7 @@ include/geos/util/GEOSException.h
include/geos/util/GeometricShapeFactory.h
include/geos/util/IllegalArgumentException.h
include/geos/util/IllegalStateException.h
+include/geos/util/Interrupt.h
include/geos/util/Machine.h
include/geos/util/TopologyException.h
include/geos/util/UniqueCoordinateArrayFilter.h
@@ -356,7 +371,7 @@ include/geos/util/UnsupportedOperationException.h
include/geos/util/math.h
include/geos/version.h
include/geos_c.h
-lib/libgeos-3.3.8.so
+lib/libgeos-3.4.1.so
lib/libgeos.a
lib/libgeos.la
lib/libgeos.so
@@ -364,9 +379,11 @@ lib/libgeos.so.0
lib/libgeos_c.a
lib/libgeos_c.la
lib/libgeos_c.so
-lib/libgeos_c.so.8
+lib/libgeos_c.so.9
@dirrmtry lib/geos
@dirrm include/geos/util
+@dirrm include/geos/triangulate/quadedge
+@dirrm include/geos/triangulate
@dirrm include/geos/simplify
@dirrm include/geos/precision
@dirrm include/geos/planargraph/algorithm
@@ -385,6 +402,7 @@ lib/libgeos_c.so.8
@dirrm include/geos/operation
@dirrm include/geos/noding/snapround
@dirrm include/geos/noding
+@dirrm include/geos/linearref
@dirrm include/geos/io
@dirrm include/geos/index/sweepline
@dirrm include/geos/index/strtree
@@ -402,18 +420,18 @@ lib/libgeos_c.so.8
@dirrm include/geos/algorithm/distance
@dirrm include/geos/algorithm
@dirrm include/geos
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/geos.pth
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.a
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.la
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.so
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/geos/geos.py
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/geos/geos.pyc
-%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/geos/geos.pyo
-%%WITH_PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/geos
-%%WITH_PYTHON%%@dirrmtry %%PYTHON_SITELIBDIR%%
-%%WITH_RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.a
-%%WITH_RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.la
-%%WITH_RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.so
-%%WITH_RUBY%%@dirrmtry %%RUBY_SITEARCHLIBDIR%%/
-%%WITH_PHP%%lib/php/20100525/geos.so
-%%WITH_PHP%%@dirrmtry lib/php/20100525
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos.pth
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.a
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.la
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.so
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/geos.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/geos.pyc
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/geos.pyo
+%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/geos
+%%PYTHON%%@dirrmtry %%PYTHON_SITELIBDIR%%
+%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.a
+%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.la
+%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.so
+%%RUBY%%@dirrmtry %%RUBY_SITEARCHLIBDIR%%/
+%%PHP%%lib/php/20100525/geos.so
+%%PHP%%@dirrmtry lib/php/20100525
diff --git a/graphics/librasterlite/Makefile b/graphics/librasterlite/Makefile
index 6c9b0e903a2c..10c455dbbc39 100644
--- a/graphics/librasterlite/Makefile
+++ b/graphics/librasterlite/Makefile
@@ -3,6 +3,7 @@
PORTNAME= librasterlite
PORTVERSION= 1.1e
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= http://www.gaia-gis.it/gaia-sins/librasterlite-sources/
diff --git a/graphics/libreatlas/Makefile b/graphics/libreatlas/Makefile
index 1a46a87eb96e..377150f1b269 100644
--- a/graphics/libreatlas/Makefile
+++ b/graphics/libreatlas/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libreatlas
PORTVERSION= 1.0.0a
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics geography
MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
index 15e7170fc1c8..bd42f935a873 100644
--- a/graphics/mapserver/Makefile
+++ b/graphics/mapserver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mapserver
PORTVERSION= 6.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics www geography
MASTER_SITES= http://download.osgeo.org/mapserver/
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index cfa971f535ef..5502318dbb6c 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qgis
PORTVERSION= 1.8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics geography
MASTER_SITES= http://qgis.org/downloads/ \
http://download.osgeo.org/qgis/src/