aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-05-21 22:56:49 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-05-21 22:56:49 +0800
commit0270a05585adcb17373baf0da15cf1978194e9c2 (patch)
treeb3d5fcb7bc312dd66f667492c306478fa2d7c355 /graphics
parentd5a2dd5a645d691ded5ef6fe0f255bdbf8c2f03d (diff)
downloadfreebsd-ports-gnome-0270a05585adcb17373baf0da15cf1978194e9c2.tar.gz
freebsd-ports-gnome-0270a05585adcb17373baf0da15cf1978194e9c2.tar.zst
freebsd-ports-gnome-0270a05585adcb17373baf0da15cf1978194e9c2.zip
Fix build with pkgconf installed
Reported by: Jan Henrik Sylvester <me@janh.de>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/podofo/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 5409f6a3f62d..b4838379695a 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -20,8 +20,9 @@ OPTIONS_DEFINE= IMPOSE JPEG PNG TIFF
OPTIONS_DEFAULT=JPEG PNG TIFF
IMPOSE_DESC= Build impose tool (Lua required)
-CMAKE_ARGS= -DOPENSSL_INCLUDE_DIR="${OPENSSLINC}" \
- -DOPENSSL_LIBRARIES="${OPENSSLDIR}" \
+CMAKE_ARGS= -DFONTCONFIG_LIBRARIES=${LOCALBASE}/lib/libfontconfig.so \
+ -DOPENSSL_INCLUDE_DIR=${OPENSSLINC} \
+ -DOPENSSL_LIBRARIES=${OPENSSLDIR} \
-DPODOFO_BUILD_SHARED=TRUE \
-DPODOFO_BUILD_STATIC=TRUE
USE_LDCONFIG= yes