aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-06-16 01:15:00 +0800
committerrakuco <rakuco@FreeBSD.org>2015-06-16 01:15:00 +0800
commit058b327f416b757dd1260089cb896481c9eadacb (patch)
treebf6d26470c8acb910639ba999b0cf231ef86d967 /graphics
parent0f89b54a0f75e045c49b11db27311aa11100e083 (diff)
downloadfreebsd-ports-gnome-058b327f416b757dd1260089cb896481c9eadacb.tar.gz
freebsd-ports-gnome-058b327f416b757dd1260089cb896481c9eadacb.tar.zst
freebsd-ports-gnome-058b327f416b757dd1260089cb896481c9eadacb.zip
Add upstream patch to fix the GCC build after r388490.
libraw 0.16.1 started shipping some code that uses C++ exceptions. KDE code, on the other hand, disables exceptions by default, and users must opt-in in CMake to use them. clang is the exception and exceptions are always enabled when using it, which is why the build did not break with it. Import an upstream commit that does exactly that. Bump PORTREVISION to make sure that all users build the port with exception support. Done in collaboration with alonso@. PR: 200734
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libkdcraw-kde4/Makefile1
-rw-r--r--graphics/libkdcraw-kde4/files/patch-git_46898ec918
2 files changed, 19 insertions, 0 deletions
diff --git a/graphics/libkdcraw-kde4/Makefile b/graphics/libkdcraw-kde4/Makefile
index d3b047f0503f..bf11f184a109 100644
--- a/graphics/libkdcraw-kde4/Makefile
+++ b/graphics/libkdcraw-kde4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libkdcraw
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/graphics/libkdcraw-kde4/files/patch-git_46898ec9 b/graphics/libkdcraw-kde4/files/patch-git_46898ec9
new file mode 100644
index 000000000000..a55ef87208b5
--- /dev/null
+++ b/graphics/libkdcraw-kde4/files/patch-git_46898ec9
@@ -0,0 +1,18 @@
+commit 46898ec97a0462eb08a5b6d09999450a86b27aae
+Author: Gilles Caulier <caulier.gilles@gmail.com>
+Date: Thu May 14 22:54:16 2015 +0200
+
+libraw 0.16.1 needs C++ exceptions rules while compilation
+BUGS: 347728
+FIXED-IN: 4.11.0
+--- libkdcraw/CMakeLists.txt
++++ libkdcraw/CMakeLists.txt
+@@ -22,6 +22,8 @@
+ #
+ # ============================================================
+
++add_definitions (${KDE4_ENABLE_EXCEPTIONS})
++
+ CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/version.h)
+
+ SET(kdcraw_LIB_SRCS kdcraw.cpp