aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-05-21 00:45:36 +0800
committermezz <mezz@FreeBSD.org>2012-05-21 00:45:36 +0800
commit0f7b755b4c443d249f17626b1ca477ed1a3075bc (patch)
tree8a1edae2d2cf61beb544431d9a2ccd052193a29f /graphics
parente62857632227552bdad675afa8cdb8865538845c (diff)
downloadfreebsd-ports-gnome-0f7b755b4c443d249f17626b1ca477ed1a3075bc.tar.gz
freebsd-ports-gnome-0f7b755b4c443d249f17626b1ca477ed1a3075bc.tar.zst
freebsd-ports-gnome-0f7b755b4c443d249f17626b1ca477ed1a3075bc.zip
The fix below moves the test to sh, which effectively ensures that the test
for existence is done at pre-configure stage rather than Makefile parse. PR: ports/166279 Submitted by: Mel Flynn <rflynn@acsalaska.net>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gtk-update-icon-cache/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/gtk-update-icon-cache/Makefile b/graphics/gtk-update-icon-cache/Makefile
index 65e829aeb4f1..b856663bdb44 100644
--- a/graphics/gtk-update-icon-cache/Makefile
+++ b/graphics/gtk-update-icon-cache/Makefile
@@ -53,10 +53,10 @@ MAN1= gtk-update-icon-cache.1
.include <bsd.port.pre.mk>
pre-configure:
-.if !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc)
- @${ECHO_CMD} "${PKGNAME}: Needs cairo build with X11 support."
- @${FALSE}
-.endif
+ @if [ ! -f ${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc ]; then \
+ ${ECHO_CMD} "${PKGNAME}: Needs cairo built with X11 support."; \
+ ${FALSE}; \
+ fi
do-build:
@cd ${WRKSRC}/gtk && ${GMAKE} gtk-update-icon-cache