aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2017-03-05 06:23:20 +0800
committerkmoore <kmoore@FreeBSD.org>2017-03-05 06:23:20 +0800
commit11c6fa0c28af3b2477a59d2dae3d75d77d2f5391 (patch)
tree84c93ea7177518f83fecc55abba14c29ad4d8514 /graphics
parent383d48e32007b45ae9975ecb9c4ca13bdaa4e184 (diff)
downloadfreebsd-ports-gnome-11c6fa0c28af3b2477a59d2dae3d75d77d2f5391.tar.gz
freebsd-ports-gnome-11c6fa0c28af3b2477a59d2dae3d75d77d2f5391.tar.zst
freebsd-ports-gnome-11c6fa0c28af3b2477a59d2dae3d75d77d2f5391.zip
- Create python3 version of graphics/py-imagesize
- Set architecture neutral PR: 217470 Submitted by: Danilo Baio <dbaio@bsd.com.br>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-imagesize/Makefile3
-rw-r--r--graphics/py3-imagesize/Makefile8
3 files changed, 11 insertions, 1 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index c07a78bb33b7..dec7cfb964c4 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -892,6 +892,7 @@
SUBDIR += py-wand
SUBDIR += py-webcolors
SUBDIR += py3-cairo
+ SUBDIR += py3-imagesize
SUBDIR += py3-pillow
SUBDIR += py3-pygraphviz
SUBDIR += pygts
diff --git a/graphics/py-imagesize/Makefile b/graphics/py-imagesize/Makefile
index 4bf442c38b05..77ccba373e44 100644
--- a/graphics/py-imagesize/Makefile
+++ b/graphics/py-imagesize/Makefile
@@ -12,7 +12,8 @@ COMMENT= Python image size library
LICENSE= MIT
-USES= python
+NO_ARCH= yes
+USES?= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/graphics/py3-imagesize/Makefile b/graphics/py3-imagesize/Makefile
new file mode 100644
index 000000000000..8b51d361bf88
--- /dev/null
+++ b/graphics/py3-imagesize/Makefile
@@ -0,0 +1,8 @@
+# Created by: Danilo G. Baio <dbaio@bsd.com.br>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-imagesize
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"