aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-27 21:27:09 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-27 21:27:09 +0800
commit2e7b0a463cec6802acb4f4e9f848878be6eda68c (patch)
treedaa4e2aec00b3daedf84a07984861213fd3e991a /graphics
parentafcab4b2650c9589dfbfe224e8afe13b1d74da57 (diff)
downloadfreebsd-ports-gnome-2e7b0a463cec6802acb4f4e9f848878be6eda68c.tar.gz
freebsd-ports-gnome-2e7b0a463cec6802acb4f4e9f848878be6eda68c.tar.zst
freebsd-ports-gnome-2e7b0a463cec6802acb4f4e9f848878be6eda68c.zip
- Remove compiler tampering
This is no longer needed after the same thing was removed from OpenEXR, and moreover it breaks opencolorio-tools on 9.x PR: 197907 Approved by: portmgr blanket, maitainer timeout
Diffstat (limited to 'graphics')
-rw-r--r--graphics/openimageio/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index 3e907c1c4130..764c3188116b 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openimageio
PORTVERSION= 1.4.15
DISTVERSIONPREFIX= Release-
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= graphics multimedia
MAINTAINER?= FreeBSD@Shaneware.biz
@@ -19,7 +19,7 @@ GH_PROJECT= oiio
# fbm also installs bin/idiff
CONFLICTS= fbm-[0-9]*
-USES= cmake:outsource compiler
+USES= cmake:outsource
CMAKE_ARGS= -DBUILDSTATIC:BOOL=OFF \
-DLINKSTATIC:BOOL=OFF \
-DNOTHREADS:BOOL=OFF \
@@ -70,13 +70,6 @@ CMAKE_ENV+= QTDIR=${QT_PREFIX} QT_INCLUDES=${QT_INCDIR}
CMAKE_ARGS+= -DUSE_OPENGL:BOOL=OFF -DUSE_QT:BOOL=OFF
.endif
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == gcc
-# GCC 4.2 does not link with other ports that now use GCC 4.9 or later.
-USE_GCC= yes
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|share/doc/OpenImageIO|${DOCSDIR}|g' \
${WRKSRC}/CMakeLists.txt
@@ -87,4 +80,4 @@ post-install:
${LN} -sf libOpenImageIO_Util.so.1.4 ${STAGEDIR}${PREFIX}/lib/libOpenImageIO_Util.so.1
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>