aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2003-01-04 08:02:42 +0800
committeralane <alane@FreeBSD.org>2003-01-04 08:02:42 +0800
commit2e8949bbecf147a78d50599af931b98d999ab546 (patch)
treeeaf7870daff4e1ade4c1676718c4ce464b6a349c /graphics
parentbafb0d9d22a840e897858553471a3d21bc848678 (diff)
downloadfreebsd-ports-gnome-2e8949bbecf147a78d50599af931b98d999ab546.tar.gz
freebsd-ports-gnome-2e8949bbecf147a78d50599af931b98d999ab546.tar.zst
freebsd-ports-gnome-2e8949bbecf147a78d50599af931b98d999ab546.zip
Fix .mgp files so they don't contain the Linux demo text but are suitable
for %include at top of your presentation.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mgp-gallery/Makefile5
-rw-r--r--graphics/mgp-gallery/scripts/fix-gallery11
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/mgp-gallery/Makefile b/graphics/mgp-gallery/Makefile
index 4954a9425db6..895efd9f04b7 100644
--- a/graphics/mgp-gallery/Makefile
+++ b/graphics/mgp-gallery/Makefile
@@ -9,7 +9,7 @@
PORTNAME= mgp-gallery
PORTVERSION= 2.0
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 0
CATEGORIES= graphics
MASTER_SITES= http://puchol.com/cpg/software/mgp/
@@ -40,7 +40,8 @@ do-install:
.for i in midgard backgrounds solid gradients
${MKDIR} ${PKGDATADIR}/${i}
cd ${WRKDIR}/mgp-${i}-${PORTVERSION};\
- ${INSTALL_DATA} * ${PKGDATADIR}/${i}
+ ${INSTALL_DATA} * ${PKGDATADIR}/${i};\
+ ${SCRIPTDIR}/fix-gallery "${INSTALL_DATA}" ${PKGDATADIR}/${i} *.mgp
.endfor # i in midgard backgrounds solid gradient
cd ${PREFIX};\
${RM} -f ${PLIST};\
diff --git a/graphics/mgp-gallery/scripts/fix-gallery b/graphics/mgp-gallery/scripts/fix-gallery
new file mode 100644
index 000000000000..1286c1b92855
--- /dev/null
+++ b/graphics/mgp-gallery/scripts/fix-gallery
@@ -0,0 +1,11 @@
+#!/bin/sh
+INSTALL="$1"
+TARGETDIR="$2"
+shift 2
+while test $# -gt 0; do
+ input=$1
+ shift
+ sed -e "1d" -e "/^%nodefault/q" <$input >.$input
+ $INSTALL .$input $TARGETDIR/$input
+ rm -f .$input
+done