aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2015-06-28 22:24:25 +0800
committeravilla <avilla@FreeBSD.org>2015-06-28 22:24:25 +0800
commit34bea031885feacc661f85ccb59ec368a8aadfd4 (patch)
tree7622360c65b715d17c0a80821492463241b24ca6 /graphics
parent69bacd484d76387744e19bb80ca06e1606ce8d33 (diff)
downloadfreebsd-ports-gnome-34bea031885feacc661f85ccb59ec368a8aadfd4.tar.gz
freebsd-ports-gnome-34bea031885feacc661f85ccb59ec368a8aadfd4.tar.zst
freebsd-ports-gnome-34bea031885feacc661f85ccb59ec368a8aadfd4.zip
graphics/opengtl: fix build with LLVM 3.3
PR: 201022 Submitted by: matthew@reztek.cz Obtained from: Gentoo MFH: 2015Q2
Diffstat (limited to 'graphics')
-rw-r--r--graphics/opengtl/Makefile15
-rw-r--r--graphics/opengtl/distinfo2
-rw-r--r--graphics/qtgtl/Makefile3
3 files changed, 9 insertions, 11 deletions
diff --git a/graphics/opengtl/Makefile b/graphics/opengtl/Makefile
index a8da87dc3215..2235bd7e98da 100644
--- a/graphics/opengtl/Makefile
+++ b/graphics/opengtl/Makefile
@@ -2,26 +2,25 @@
PORTNAME= opengtl
PORTVERSION= 0.9.18
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics devel
MASTER_SITES= http://download.${PORTNAME}.org/
DISTNAME= OpenGTL-${PORTVERSION}
+PATCH_SITES= http://dev.gentoo.org/~creffett/distfiles/
+PATCHFILES= ${PORTNAME}-${PORTVERSION}-llvm-3.3.patch
+PATCH_DIST_STRIP=-p1
MAINTAINER= avilla@FreeBSD.org
COMMENT= Graphics Transformation Languages
LICENSE= LGPL20
-BROKEN= Depends on deleted devel/llvm32
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2015-07-21
-
-#LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
-# libLLVM-3.2.so:${PORTSDIR}/devel/llvm32
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libLLVM-3.3.so:${PORTSDIR}/devel/llvm33
USES= cmake perl5 tar:bzip2
USE_LDCONFIG= yes
-CMAKE_ARGS= -DLLVM_CONFIG_EXECUTABLE=${LOCALBASE}/bin/llvm-config32
+CMAKE_ARGS= -DLLVM_CONFIG_EXECUTABLE=${LOCALBASE}/bin/llvm-config33
PLIST_SUB+= PORTVERSION=${PORTVERSION}
diff --git a/graphics/opengtl/distinfo b/graphics/opengtl/distinfo
index 150a02937827..f2eea8cb4e3f 100644
--- a/graphics/opengtl/distinfo
+++ b/graphics/opengtl/distinfo
@@ -1,2 +1,4 @@
SHA256 (OpenGTL-0.9.18.tar.bz2) = f094b3d2a1a60519975bb3badc05e704f2b93c7a3d2cb753041f2ff27cfcd9f8
SIZE (OpenGTL-0.9.18.tar.bz2) = 536113
+SHA256 (opengtl-0.9.18-llvm-3.3.patch) = c43418bc039660ae86cb86b8b8175342793cb1361c699faa9b6342bc896e3d6c
+SIZE (opengtl-0.9.18-llvm-3.3.patch) = 27930
diff --git a/graphics/qtgtl/Makefile b/graphics/qtgtl/Makefile
index edd40c33538e..6feaeb332fc5 100644
--- a/graphics/qtgtl/Makefile
+++ b/graphics/qtgtl/Makefile
@@ -11,9 +11,6 @@ COMMENT= Qt bindings for the Graphics Transformation Languages
LICENSE= LGPL20
-DEPRECATED= Depends on broken and expiring graphics/opengtl
-EXPIRATION_DATE= 2015-07-21
-
LIB_DEPENDS= libGTLCore.so:${PORTSDIR}/graphics/opengtl
USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build