aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorler <ler@FreeBSD.org>2017-10-26 12:54:37 +0800
committerler <ler@FreeBSD.org>2017-10-26 12:54:37 +0800
commit35779cfbea33f962794758ecd690172148761359 (patch)
tree280fc62324765608a4d2e4d9910729cad058c6ae /graphics
parent91a0ea17a39f2c42d5522e92ee7ddd4f95b4d5db (diff)
downloadfreebsd-ports-gnome-35779cfbea33f962794758ecd690172148761359.tar.gz
freebsd-ports-gnome-35779cfbea33f962794758ecd690172148761359.tar.zst
freebsd-ports-gnome-35779cfbea33f962794758ecd690172148761359.zip
graphics/opencv, graphics/py-opencv: Add USES = fortran, bump portrevisions
PR: 211806 Submitted by: eric@camachat.org Reported by: hassonofer@gmail.com
Diffstat (limited to 'graphics')
-rw-r--r--graphics/opencv/Makefile4
-rw-r--r--graphics/py-opencv/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 184a8ebad0ae..565cdc2109f4 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= opencv
PORTVERSION= 2.4.13.1
-PORTREVISION?= 8
+PORTREVISION?= 9
CATEGORIES= graphics
MAINTAINER= ports@FreeBSD.org
@@ -141,7 +141,7 @@ CMAKE_ARGS+= -DBUILD_opencv_${module}:BOOL=Off
LIB_DEPENDS+= libopencv_legacy.so:graphics/opencv
BUILD_DEPENDS+= ${PYNUMPY}
RUN_DEPENDS+= ${PYNUMPY}
-USES+= python:2.7
+USES+= fortran python:2.7
CMAKE_ARGS+= -DBUILD_opencv_python:BOOL=On
. for module in apps java stitching superres videostab
CMAKE_ARGS+= -DBUILD_opencv_${module}:BOOL=Off
diff --git a/graphics/py-opencv/Makefile b/graphics/py-opencv/Makefile
index a8b1562a09b5..ccd2589e5399 100644
--- a/graphics/py-opencv/Makefile
+++ b/graphics/py-opencv/Makefile
@@ -1,7 +1,7 @@
# Created by: Martin Matuska <mm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}