aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2017-02-28 05:15:12 +0800
committerdanfe <danfe@FreeBSD.org>2017-02-28 05:15:12 +0800
commit37508dd55c9d1296be9289321be66fb4ba4a99ae (patch)
treea0538ac570cbcdbef7a6f163d9d33ef0e66801eb /graphics
parent4c5b349b28f0e252e5377573f2336f1a9bb5cea2 (diff)
downloadfreebsd-ports-gnome-37508dd55c9d1296be9289321be66fb4ba4a99ae.tar.gz
freebsd-ports-gnome-37508dd55c9d1296be9289321be66fb4ba4a99ae.tar.zst
freebsd-ports-gnome-37508dd55c9d1296be9289321be66fb4ba4a99ae.zip
- Prefer to build and install shared library rather than static one
- Convert explicit LIB_DEPENDS to their USE_XORG equivalents - Utilize USES+=localbase instead of manually amending CPPFLAGS/LDFLAGS - Drop USE_GCC=yes: the port builds fine with both Clang and GCC 4.2.1 (e.g. on PowerPC)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/glfw/Makefile13
-rw-r--r--graphics/glfw/pkg-plist4
2 files changed, 7 insertions, 10 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index b203c1ddc3ad..0585f54f09d0 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -3,6 +3,7 @@
PORTNAME= glfw
PORTVERSION= 3.2.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF
@@ -11,17 +12,11 @@ COMMENT= Portable framework for OpenGL development
LICENSE= ZLIB
-LIB_DEPENDS= libXinerama.so:x11/libXinerama \
- libXcursor.so:x11/libXcursor
-
-USES= cmake zip
-USE_XORG= xi xrandr
+USES= cmake localbase zip
+USE_XORG= x11 xcursor xinerama xrandr xxf86vm
USE_GL= glu
-USE_GCC= yes
USE_LDCONFIG= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CMAKE_ARGS= -DBUILD_SHARED_LIBS:BOOL=ON
PORTDOCS= *
diff --git a/graphics/glfw/pkg-plist b/graphics/glfw/pkg-plist
index f4dd3cbcdc2b..c230c22e3dea 100644
--- a/graphics/glfw/pkg-plist
+++ b/graphics/glfw/pkg-plist
@@ -4,5 +4,7 @@ lib/cmake/glfw3/glfw3Config.cmake
lib/cmake/glfw3/glfw3ConfigVersion.cmake
lib/cmake/glfw3/glfw3Targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/glfw3/glfw3Targets.cmake
-lib/libglfw3.a
+lib/libglfw.so
+lib/libglfw.so.3
+lib/libglfw.so.3.2
libdata/pkgconfig/glfw3.pc