aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-11-25 00:33:15 +0800
committerdanfe <danfe@FreeBSD.org>2015-11-25 00:33:15 +0800
commit3ec5b19386356254ee2c6226a754af6e08b8964d (patch)
tree47c3f7a5f7b759c9212fbea6d97bcb77967b3cf1 /graphics
parent5234cd6d8a7b322d978799e64fdfc52573b61ecb (diff)
downloadfreebsd-ports-gnome-3ec5b19386356254ee2c6226a754af6e08b8964d.tar.gz
freebsd-ports-gnome-3ec5b19386356254ee2c6226a754af6e08b8964d.tar.zst
freebsd-ports-gnome-3ec5b19386356254ee2c6226a754af6e08b8964d.zip
- Update to version 1.5.1 which fixes a few annoying issues with glossy
materials when using the new LuxCore rendering modes - Because upstream did not use different tag names for LuxCore and LuxRender this time, avoid distfile name clash by using .tar.gz format for smaller distfile (3.1M) and .tar.bz2 for the larger one (28M) - Ensure that correct build number is reported in the "About" dialog box - Fix USES and DISTVERSION check for version 1.4 support while I'm here
Diffstat (limited to 'graphics')
-rw-r--r--graphics/luxrender/Makefile13
-rw-r--r--graphics/luxrender/distinfo8
-rw-r--r--graphics/luxrender14/Makefile2
3 files changed, 13 insertions, 10 deletions
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index 9b903ce7292c..0e8c647a0304 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= luxrender
-DISTVERSION?= 1.5
+DISTVERSION?= 1.5.1
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/luxrender/lux/get/ \
https://bitbucket.org/luxrender/luxrays/get/:lr
-DISTFILES= v${DISTVERSION:C/[.-]//g}${EXTRACT_SUFX} \
+DISTFILES?= ${PORTNAME}_v${DISTVERSION}.tar.gz \
${PORTNAME}_v${DISTVERSION:S/-//}${EXTRACT_SUFX}:lr
DIST_SUBDIR= ${PORTNAME}
@@ -19,14 +19,14 @@ LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libfreeimage.so:${PORTSDIR}/graphics/freeimage \
libOpenImageIO.so:${PORTSDIR}/graphics/openimageio
-.if ${DISTVERSION} > 1.4
+.if ${DISTVERSION} != 1.4
LIB_DEPENDS+= libembree.so:${PORTSDIR}/graphics/embree
.endif
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= uses SSE instructions
-USES= bison cmake execinfo python:version tar:bzip2
+USES= bison cmake execinfo python:build tar:bzip2
USE_GL= glut glew
WRKSRC= ${WRKDIR}/${PORTNAME}-lux-${LUX_REV}
LUXRAYS_WRKSRC= ${WRKDIR}/${PORTNAME}-luxrays-${LUXRAYS_REV}
@@ -39,8 +39,8 @@ CMAKE_ARGS= -DLUXCORE_INCLUDE_DIRS:PATH="${LUXRAYS_WRKSRC}/include" \
-DSLG_LIBRARY:PATH="${LUXRAYS_WRKSRC}/lib/libsmallluxgpu.a" \
-DLUXRAYS_DISABLE_OPENCL:BOOL=ON
-LUX_REV?= 216e294b59e3
-LUXRAYS_REV?= 3674460aa1da
+LUX_REV?= 8dabcd6b7016
+LUXRAYS_REV?= 8577ff287efb
OPTIONS_DEFINE= X11
OPTIONS_DEFAULT= X11
@@ -66,6 +66,7 @@ post-patch:
${WRKSRC}/cmake/pylux.cmake
pre-configure:
+ -${PYTHON_CMD} ${WRKSRC}/makeBuildNumber.py ${WRKSRC}/core/version.h
cd ${LUXRAYS_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} \
${CMAKE_ARGS} .
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
diff --git a/graphics/luxrender/distinfo b/graphics/luxrender/distinfo
index 120b4b12b53c..f64459f86e6f 100644
--- a/graphics/luxrender/distinfo
+++ b/graphics/luxrender/distinfo
@@ -1,4 +1,4 @@
-SHA256 (luxrender/v15.tar.bz2) = 5336ef37388e68414aa6f6e2ad43df5aa384e1cb7d73b2f68b4be02d10adade4
-SIZE (luxrender/v15.tar.bz2) = 2419335
-SHA256 (luxrender/luxrender_v1.5.tar.bz2) = 6aea4af2faa09460f8e77997e40855a8f978f15a4ddebdc6d67ee7bbf127d04f
-SIZE (luxrender/luxrender_v1.5.tar.bz2) = 29612786
+SHA256 (luxrender/luxrender_v1.5.1.tar.gz) = 6f55594759c7580bc9b08d517fc23a4e7c2e2195e8ad367e87ba1a3a2216f3e2
+SIZE (luxrender/luxrender_v1.5.1.tar.gz) = 3267994
+SHA256 (luxrender/luxrender_v1.5.1.tar.bz2) = 551ce7506f04a51f59c262cb47dd03db5db1d4a0d3cd7f43d7b4dbb10ddd94cc
+SIZE (luxrender/luxrender_v1.5.1.tar.bz2) = 29613457
diff --git a/graphics/luxrender14/Makefile b/graphics/luxrender14/Makefile
index 6f1b5c019f1f..26c96db8f5bc 100644
--- a/graphics/luxrender14/Makefile
+++ b/graphics/luxrender14/Makefile
@@ -2,6 +2,8 @@
# $FreeBSD$
DISTVERSION= 1.4
+DISTFILES= v${DISTVERSION:C/[.-]//g}${EXTRACT_SUFX} \
+ ${PORTNAME}_v${DISTVERSION:S/-//}${EXTRACT_SUFX}:lr
LUX_REV= dfd211d6faa0
LUXRAYS_REV= 7c7127ee1fa4