aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
commit41290677b018da2819144b0188ac8bd1b91a88e4 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /graphics
parent02239bfdfc92a832c32cc57d07d3a1a4b3fc4ad9 (diff)
downloadfreebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.gz
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.zst
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/graphite2/Makefile2
-rw-r--r--graphics/ida/Makefile2
-rw-r--r--graphics/ipe/Makefile2
-rw-r--r--graphics/libgaiagraphics/Makefile2
-rw-r--r--graphics/netpbm/files/patch-lib-util-pm_c_util.h10
-rw-r--r--graphics/oyranos/Makefile2
6 files changed, 15 insertions, 5 deletions
diff --git a/graphics/graphite2/Makefile b/graphics/graphite2/Makefile
index f73b04085048..b4c703089c38 100644
--- a/graphics/graphite2/Makefile
+++ b/graphics/graphite2/Makefile
@@ -11,7 +11,7 @@ COMMENT= Rendering capabilities for complex non-Roman writing systems
USES= cmake iconv
USE_LDCONFIG= yes
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
post-patch:
@${REINPLACE_CMD} -e 's,/pkgconfig,data/pkgconfig,g' ${WRKSRC}/CMakeLists.txt
diff --git a/graphics/ida/Makefile b/graphics/ida/Makefile
index cb017dcb9a2e..8b90ebe4668d 100644
--- a/graphics/ida/Makefile
+++ b/graphics/ida/Makefile
@@ -26,7 +26,7 @@ USES= iconv gmake motif perl5
MAKEFILE= GNUmakefile
MAKE_ARGS= JPEG_VER=80 verbose=yes
-LDFLAGS+= -liconv
+LDFLAGS+= ${ICONV_LIB}
MAN1= exiftran.1 ida.1
PORTDOCS= README TODO INSTALL
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 725c25601d54..30b2e4e182a0 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -26,7 +26,7 @@ USE_TEX= latex
USE_GMAKE= yes
MAKE_ENV= DLL_CFLAGS="-fPIC" \
ICONV_CFLAGS="-I${LOCALBASE}/include" \
- ICONV_LIBS="-L${LOCALBASE}/lib -liconv" \
+ ICONV_LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}" \
INSTALL_DIR="${MKDIR}" \
INSTALL_FILES="${INSTALL_DATA}" \
INSTALL_SCRIPTS="${INSTALL_SCRIPT}" \
diff --git a/graphics/libgaiagraphics/Makefile b/graphics/libgaiagraphics/Makefile
index 2b75a31c5d29..ae5d4902845b 100644
--- a/graphics/libgaiagraphics/Makefile
+++ b/graphics/libgaiagraphics/Makefile
@@ -19,7 +19,7 @@ GNU_CONFIGURE= yes
USES= iconv gmake pkgconfig
CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+=CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
diff --git a/graphics/netpbm/files/patch-lib-util-pm_c_util.h b/graphics/netpbm/files/patch-lib-util-pm_c_util.h
new file mode 100644
index 000000000000..c630a8411eef
--- /dev/null
+++ b/graphics/netpbm/files/patch-lib-util-pm_c_util.h
@@ -0,0 +1,10 @@
+--- lib/util/pm_c_util.h.orig 2006-08-19 05:12:28.000000000 +0200
++++ lib/util/pm_c_util.h 2013-08-30 13:58:20.918173431 +0200
+@@ -50,6 +50,7 @@
+ #ifndef __cplusplus
+ #ifndef HAVE_BOOL
+ #define HAVE_BOOL 1
++ #undef bool
+ typedef int bool;
+ #endif
+ #ifndef true
diff --git a/graphics/oyranos/Makefile b/graphics/oyranos/Makefile
index 070e8bdccff3..3fec69119f7e 100644
--- a/graphics/oyranos/Makefile
+++ b/graphics/oyranos/Makefile
@@ -32,7 +32,7 @@ USE_GNOME= libxml2
USE_QT4= gui moc_build qmake_build rcc_build uic_build
USE_XORG= xfixes xinerama xrandr xxf86vm
CMAKE_ARGS+= -DXDG_CONFIG_DIR=${PREFIX}/etc/xdg
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
MAN1= oyranos-config-fltk.1 oyranos-monitor-daemon.1 oyranos-monitor.1 \
oyranos-policy.1 oyranos-profile-graph.1 oyranos-profile-install.1 \