aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-06-30 11:00:15 +0800
committerswills <swills@FreeBSD.org>2012-06-30 11:00:15 +0800
commit43654981fb26a7232c0c4b527c005a28cd21597c (patch)
treeaafe090efa47c4b4061afeb07a5d1fd5053a553c /graphics
parent474c082cf36563a167db2a6fc03106a6dfdff115 (diff)
downloadfreebsd-ports-gnome-43654981fb26a7232c0c4b527c005a28cd21597c.tar.gz
freebsd-ports-gnome-43654981fb26a7232c0c4b527c005a28cd21597c.tar.zst
freebsd-ports-gnome-43654981fb26a7232c0c4b527c005a28cd21597c.zip
- Fix build on 7.x and 8.x too (previous commit fixed build on 9.x and
10-CURRENT
Diffstat (limited to 'graphics')
-rw-r--r--graphics/visionworkbench/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/visionworkbench/Makefile b/graphics/visionworkbench/Makefile
index 0f6eb0a885da..901c06e33675 100644
--- a/graphics/visionworkbench/Makefile
+++ b/graphics/visionworkbench/Makefile
@@ -45,6 +45,12 @@ CFLAGS+= -Dtgammaf=tgamma
. endif
.endif
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${LDFLAGS}"
+
pre-configure:
echo "HAVE_PKG_FLAPACK=yes" >> ${WRKSRC}/config.options
echo "PKG_FLAPACK_LDFLAGS=-L${LOCALBASE}/lib/${CC}" >> ${WRKSRC}/config.options