aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2017-09-30 03:45:27 +0800
committerswills <swills@FreeBSD.org>2017-09-30 03:45:27 +0800
commit483e3ca33def0baf022a27fe2e25576c6475b6b0 (patch)
tree50cc1486bdbba5f11e292068a01159653e7ed8a5 /graphics
parent88d75dcfceb89d332ce23b83ed19d48ad6f5f96c (diff)
downloadfreebsd-ports-gnome-483e3ca33def0baf022a27fe2e25576c6475b6b0.tar.gz
freebsd-ports-gnome-483e3ca33def0baf022a27fe2e25576c6475b6b0.tar.zst
freebsd-ports-gnome-483e3ca33def0baf022a27fe2e25576c6475b6b0.zip
graphics/pngcrush: Update to 1.8.13
PR: 222517 Submitted by: lightside <lightside@gmx.com> Approved by: Anton Sayetsky <vsasjason@gmail.com> (maintainer)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/pngcrush/Makefile22
-rw-r--r--graphics/pngcrush/distinfo6
-rw-r--r--graphics/pngcrush/files/patch-Makefile29
3 files changed, 18 insertions, 39 deletions
diff --git a/graphics/pngcrush/Makefile b/graphics/pngcrush/Makefile
index 868cb6a9bf1d..be904dcbf12c 100644
--- a/graphics/pngcrush/Makefile
+++ b/graphics/pngcrush/Makefile
@@ -2,24 +2,32 @@
# $FreeBSD$
PORTNAME= pngcrush
-PORTVERSION= 1.8.7
+PORTVERSION= 1.8.13
CATEGORIES= graphics
-MASTER_SITES= SF/pmt/${PORTNAME}/old-versions/${PORTVERSION:R}/${PORTVERSION}/
-# # SF/pmt/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= SF/pmt/${PORTNAME}/${PORTVERSION}/ \
+ SF/pmt/${PORTNAME}/old-versions/${PORTVERSION:R}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-nolib
MAINTAINER= vsasjason@gmail.com
COMMENT= Optimizer for PNG files
+LICENSE= Pngcrush
+LICENSE_NAME= Pngcrush License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
LIB_DEPENDS= libpng.so:graphics/png
-USES= tar:xz
-CFLAGS+= -DPNGCRUSH_COUNT_COLORS -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}"
+USES= localbase:ldflags tar:xz
+MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LD="${CC}" \
+ LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/pngcrush
+post-patch:
+ @${REINPLACE_CMD} -e '/^LIBS/s|-L$$([[:alnum:]]*) ||g' \
+ ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/pngcrush
diff --git a/graphics/pngcrush/distinfo b/graphics/pngcrush/distinfo
index 3b793382e728..1b0932380c93 100644
--- a/graphics/pngcrush/distinfo
+++ b/graphics/pngcrush/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477914424
-SHA256 (pngcrush-1.8.7-nolib.tar.xz) = f0cfc0d6f4df67106a184600f891b164875b6be7173111c87bec48a509fac60b
-SIZE (pngcrush-1.8.7-nolib.tar.xz) = 64556
+TIMESTAMP = 1504041316
+SHA256 (pngcrush-1.8.13-nolib.tar.xz) = 3b4eac8c5c69fe0894ad63534acedf6375b420f7038f7fc003346dd352618350
+SIZE (pngcrush-1.8.13-nolib.tar.xz) = 66104
diff --git a/graphics/pngcrush/files/patch-Makefile b/graphics/pngcrush/files/patch-Makefile
deleted file mode 100644
index aab7b3fb59ba..000000000000
--- a/graphics/pngcrush/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./Makefile.orig 2013-06-02 13:08:48.000000000 +0300
-+++ ./Makefile 2013-06-02 13:10:53.000000000 +0300
-@@ -11,11 +11,11 @@
- # macros --------------------------------------------------------------------
-
- # uncomment these 2 lines only if you are using an external copy of libpng:
--PNGINC = ${HOME}/include
--PNGLIB = ${HOME}/lib
-+#PNGINC = ${HOME}/include
-+#PNGLIB = ${HOME}/lib
- # uncomment these 2 lines only if you are using an external copy of zlib:
--ZINC = ${HOME}/include
--ZLIB = ${HOME}/lib
-+#ZINC = ${HOME}/include
-+#ZLIB = ${HOME}/lib
-
- CC = gcc
- LD = gcc
-@@ -31,8 +31,8 @@
- PNGCRUSH = pngcrush
-
- # LIBS = -lm
--LIBS = -L$(PNGLIB) -lpng -lz -lm
--# LIBS = -lpng -lz -lm
-+#LIBS = -L$(PNGLIB) -lpng -lz -lm
-+LIBS = -lpng -lz -lm
- #LIBS = ${ZLIB}/libz.a -lm
-
- # uncomment these 4 lines only if you are NOT using an external copy of zlib: