aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2014-03-07 16:42:59 +0800
committerthierry <thierry@FreeBSD.org>2014-03-07 16:42:59 +0800
commit594e615dd12cf4ea03373c6ec887591f27836c8e (patch)
tree6b87b654e05bb6bdca606738f5201b4f54883fe7 /graphics
parent6bbea0d867be345bc5d9b762335c02db94f7ac11 (diff)
downloadfreebsd-ports-gnome-594e615dd12cf4ea03373c6ec887591f27836c8e.tar.gz
freebsd-ports-gnome-594e615dd12cf4ea03373c6ec887591f27836c8e.tar.zst
freebsd-ports-gnome-594e615dd12cf4ea03373c6ec887591f27836c8e.zip
Fix the linkage problem, even with the default options.
Reviewed by: tijl
Diffstat (limited to 'graphics')
-rw-r--r--graphics/GraphicsMagick13/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/graphics/GraphicsMagick13/Makefile b/graphics/GraphicsMagick13/Makefile
index 20fad1487ae7..d5e97fcba3e4 100644
--- a/graphics/GraphicsMagick13/Makefile
+++ b/graphics/GraphicsMagick13/Makefile
@@ -3,7 +3,7 @@
PORTNAME= GraphicsMagick
PORTVERSION= 1.3.19
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.3/
@@ -93,12 +93,6 @@ LIBWMF_PORT= libwmf-nox11
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 1000024
-.if ${PORT_OPTIONS:MFPX} && ${PORT_OPTIONS:MOPENMP}
-IGNORE= Cause C++ ABI conflict between clang/libc++ and gcc/libstdc++
-.endif
-.endif
-
.if !defined(WINDOWS_FONT_DIR)
# Use fonts installed by x11-fonts/webfonts by default
WINDOWS_FONT_DIR=${LOCALBASE}/lib/X11/fonts/webfonts
@@ -124,3 +118,6 @@ regression-test: do-build
${MAKEFILE} ${MAKE_ARGS} check)
.include <bsd.port.post.mk>
+# The OPENMP option may select gcc as compiler but on architectures
+# that have switched to libc++ clang should be used for C++ code.
+CXX= c++