aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-19 03:03:03 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-19 03:03:03 +0800
commit5c0f7ada8e3d6c1b470a20e24a47960fd0988601 (patch)
tree20084cf51a5b5184ffa5936e187493c28432f160 /graphics
parent8b85b79f4b8861323823e3e6f5c0c668f44b418c (diff)
downloadfreebsd-ports-gnome-5c0f7ada8e3d6c1b470a20e24a47960fd0988601.tar.gz
freebsd-ports-gnome-5c0f7ada8e3d6c1b470a20e24a47960fd0988601.tar.zst
freebsd-ports-gnome-5c0f7ada8e3d6c1b470a20e24a47960fd0988601.zip
Adjust USES to fix builds on gcc-based architectures.
While here, pet portlint. Tested for no regression on amd64. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ayam/Makefile2
-rw-r--r--graphics/diffpdf/Makefile2
-rw-r--r--graphics/epdfview/Makefile2
-rw-r--r--graphics/py-poppler-qt4/Makefile2
-rw-r--r--graphics/qcomicbook/Makefile2
-rw-r--r--graphics/vips/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/graphics/ayam/Makefile b/graphics/ayam/Makefile
index 1acdeeb4fdee..16943002dee1 100644
--- a/graphics/ayam/Makefile
+++ b/graphics/ayam/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils
WRKSRC= ${WRKDIR}/${PORTNAME}/src
-USES= gmake tk
+USES= compiler:c++11-lang gmake tk
USE_XORG= x11 xext xmu
USE_GL= glu
MAKE_ENV= TCL_INCLUDEDIR="${TCL_INCLUDEDIR}" \
diff --git a/graphics/diffpdf/Makefile b/graphics/diffpdf/Makefile
index f24731f9c374..f19052e0c161 100644
--- a/graphics/diffpdf/Makefile
+++ b/graphics/diffpdf/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2+
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-USES= qmake
+USES= compiler:c++11-lang qmake
USE_QT4= qmake_build moc_build rcc_build uic_build linguist_build
PLIST_FILES= bin/diffpdf
diff --git a/graphics/epdfview/Makefile b/graphics/epdfview/Makefile
index 6f25940281d9..7996266c212f 100644
--- a/graphics/epdfview/Makefile
+++ b/graphics/epdfview/Makefile
@@ -18,9 +18,9 @@ LICENSE= GPLv2
BUILD_DEPENDS= cppunit-config:devel/cppunit
LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
+USES= compiler:c++11-lang desktop-file-utils iconv gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USES= desktop-file-utils iconv gmake pkgconfig tar:bzip2
USE_GNOME= gtk20 intlhack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/py-poppler-qt4/Makefile b/graphics/py-poppler-qt4/Makefile
index 0f8bb2ae9d22..387aa4b194dd 100644
--- a/graphics/py-poppler-qt4/Makefile
+++ b/graphics/py-poppler-qt4/Makefile
@@ -16,7 +16,7 @@ LICENSE_COMB= dual
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-USES= pkgconfig pyqt:4 python
+USES= compiler:c++11-lang pkgconfig pyqt:4 python
USE_PYQT= gui xml sip_build
USE_PYTHON= distutils autoplist
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index 21f9784c295d..ecac4b6fa55d 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-USES= cmake:outsource pkgconfig
+USES= cmake:outsource compiler:c++11-lang pkgconfig
USE_QT4= corelib gui linguisttools_build moc_build qmake_build rcc_build \
uic_build xml
diff --git a/graphics/vips/Makefile b/graphics/vips/Makefile
index 5ba5286ba7fe..5b877ed989d8 100644
--- a/graphics/vips/Makefile
+++ b/graphics/vips/Makefile
@@ -34,7 +34,7 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libhdf5.so:science/hdf5 \
libexpat.so:textproc/expat2
-USES= cpe gettext gmake jpeg libtool pathfix pkgconfig python:2.7 shebangfix
+USES= compiler:c++11-lang cpe gettext gmake jpeg libtool pathfix pkgconfig python:2.7 shebangfix
SHEBANG_FILES= tools/vips-${PORTVERSION:R} tools/vipsprofile
USE_GNOME= cairo gdkpixbuf2 glib20 libgsf librsvg2 libxml2 pango
GNU_CONFIGURE= yes