aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-02-07 02:33:13 +0800
committerijliao <ijliao@FreeBSD.org>2003-02-07 02:33:13 +0800
commit5fa0dcbbccb22cbda483a4e4b78d08fa7f8f0be7 (patch)
treee1d924e74271099ba3892edc0f05f5165ae52e4d /graphics
parentfb804f3eef5873ce7ac85fd2254880071a73b49b (diff)
downloadfreebsd-ports-gnome-5fa0dcbbccb22cbda483a4e4b78d08fa7f8f0be7.tar.gz
freebsd-ports-gnome-5fa0dcbbccb22cbda483a4e4b78d08fa7f8f0be7.tar.zst
freebsd-ports-gnome-5fa0dcbbccb22cbda483a4e4b78d08fa7f8f0be7.zip
add sam2p 0.42
Converts raster (bitmap) image formats into PS or PDF files
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/sam2p/Makefile31
-rw-r--r--graphics/sam2p/distinfo1
-rw-r--r--graphics/sam2p/files/patch-configure11
-rw-r--r--graphics/sam2p/files/patch-gensio.cpp14
-rw-r--r--graphics/sam2p/pkg-comment1
-rw-r--r--graphics/sam2p/pkg-descr9
-rw-r--r--graphics/sam2p/pkg-plist1
8 files changed, 69 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 338287e63d5b..e70814060054 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -339,6 +339,7 @@
SUBDIR += ruby-svg
SUBDIR += ruby-tgif
SUBDIR += s10sh
+ SUBDIR += sam2p
SUBDIR += sane-backends
SUBDIR += sane-frontends
SUBDIR += sced
diff --git a/graphics/sam2p/Makefile b/graphics/sam2p/Makefile
new file mode 100644
index 000000000000..bf37f782f437
--- /dev/null
+++ b/graphics/sam2p/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: sam2p
+# Date created: Jan 7, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sam2p
+PORTVERSION= 0.42
+CATEGORIES= graphics
+MASTER_SITES= http://www.inf.bme.hu/~pts/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= tif22pnm:${PORTSDIR}/graphics/tif22pnm \
+ tifftopnm:${PORTSDIR}/graphics/netpbm \
+ gs:${PORTSDIR}/print/ghostscript-gnu \
+ zip:${PORTSDIR}/archivers/zip \
+ bash:${PORTSDIR}/shells/bash2
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+
+USE_PERL5_BUILD= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+ALL_TARGET= # empty
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sam2p ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/sam2p/distinfo b/graphics/sam2p/distinfo
new file mode 100644
index 000000000000..0c5090fbf9ef
--- /dev/null
+++ b/graphics/sam2p/distinfo
@@ -0,0 +1 @@
+MD5 (sam2p-0.42.tar.gz) = 98cf365e7951f0580a5641976d05133c
diff --git a/graphics/sam2p/files/patch-configure b/graphics/sam2p/files/patch-configure
new file mode 100644
index 000000000000..2c479edcf68a
--- /dev/null
+++ b/graphics/sam2p/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Feb 7 02:07:46 2003
++++ configure Fri Feb 7 02:08:00 2003
+@@ -7420,7 +7420,7 @@
+ ac_n="${ac_n:-$ECHO_N}"
+ echo $ac_n "running make Makedep""... $ac_c" 1>&6
+ echo "configure:7422: running make Makedep" >&5
+-if >&5 2>&5 make Makedep; then :
++if >&5 2>&5 gmake Makedep; then :
+ echo "$as_me:$LINENO: result: ok" >&5
+ echo "${ECHO_T}ok" >&6
+
diff --git a/graphics/sam2p/files/patch-gensio.cpp b/graphics/sam2p/files/patch-gensio.cpp
new file mode 100644
index 000000000000..aed13acf08dd
--- /dev/null
+++ b/graphics/sam2p/files/patch-gensio.cpp
@@ -0,0 +1,14 @@
+--- gensio.cpp.orig Fri Feb 7 02:24:56 2003
++++ gensio.cpp Fri Feb 7 02:25:11 2003
+@@ -491,11 +491,7 @@
+ /* --- */
+
+
+-#if HAVE_lstat_in_sys_stat
+-# define PTS_lstat lstat
+-#else
+ # define PTS_lstat stat
+-#endif
+
+ /** @param fname must start with '/' (dir separator)
+ * @return true if file successfully created
diff --git a/graphics/sam2p/pkg-comment b/graphics/sam2p/pkg-comment
new file mode 100644
index 000000000000..bfef1a999346
--- /dev/null
+++ b/graphics/sam2p/pkg-comment
@@ -0,0 +1 @@
+Converts raster (bitmap) image formats into PS or PDF files
diff --git a/graphics/sam2p/pkg-descr b/graphics/sam2p/pkg-descr
new file mode 100644
index 000000000000..46d5a446ad53
--- /dev/null
+++ b/graphics/sam2p/pkg-descr
@@ -0,0 +1,9 @@
+sam2p is a UNIX command line utility written in ANSI C++ that converts many
+raster (bitmap) image formats into Adobe PostScript or PDF files and several
+other formats. The images are not vectorized. sam2p gives full control to the
+user to specify standards-compliance, compression, and bit depths. In some
+cases sam2p can compress an image 100 times smaller than the PostScript output
+of many other common image converters. sam2p provides ZIP, RLE and LZW
+(de)compression filters even on Level1 devices.
+
+WWW: http://www.inf.bme.hu/~pts/sam2p/
diff --git a/graphics/sam2p/pkg-plist b/graphics/sam2p/pkg-plist
new file mode 100644
index 000000000000..f24b8014297e
--- /dev/null
+++ b/graphics/sam2p/pkg-plist
@@ -0,0 +1 @@
+bin/sam2p