aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2003-07-06 11:34:56 +0800
committerkuriyama <kuriyama@FreeBSD.org>2003-07-06 11:34:56 +0800
commit62062be5e0f0812b2767852057854bd0583a5568 (patch)
treedb1198d9c2fecefb89c496276363be652776c3b0 /graphics
parent39eb514550ba5cf82b23450a49dd3e4b2e209d95 (diff)
downloadfreebsd-ports-gnome-62062be5e0f0812b2767852057854bd0583a5568.tar.gz
freebsd-ports-gnome-62062be5e0f0812b2767852057854bd0583a5568.tar.zst
freebsd-ports-gnome-62062be5e0f0812b2767852057854bd0583a5568.zip
Update to 2.07.
Submitted by: Mathieu Arnold <m@absolight.net> PR: ports/52238
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-GD2/Makefile4
-rw-r--r--graphics/p5-GD2/distinfo2
-rw-r--r--graphics/p5-GD2/files/patch-GD.xs33
-rw-r--r--graphics/p5-GD2/files/patch-aa78
-rw-r--r--graphics/p5-GD2/pkg-plist18
5 files changed, 45 insertions, 90 deletions
diff --git a/graphics/p5-GD2/Makefile b/graphics/p5-GD2/Makefile
index b72f39f905d0..8339bceeb891 100644
--- a/graphics/p5-GD2/Makefile
+++ b/graphics/p5-GD2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= GD2
-PORTVERSION= 2.06
+PORTVERSION= 2.07
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= GD
@@ -19,8 +19,8 @@ COMMENT= A perl5 interface to Gd Graphics Library version2
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
PERL_CONFIGURE= yes
+CONFIGURE_ARGS= -options "JPEG,FT,XPM" -lib_gd_path ${LOCALBASE} -lib_ft_path ${X11BASE} -lib_png_path ${LOCALBASE} -lib_zlib_path ${LOCALBASE}
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= GD.3 GD::Polyline.3
.include <bsd.port.mk>
diff --git a/graphics/p5-GD2/distinfo b/graphics/p5-GD2/distinfo
index 6420c11a9316..8c7737fc0055 100644
--- a/graphics/p5-GD2/distinfo
+++ b/graphics/p5-GD2/distinfo
@@ -1 +1 @@
-MD5 (GD-2.06.tar.gz) = 90025c06e22c91e22588cee1567d3c7c
+MD5 (GD-2.07.tar.gz) = 7a44d308e082471e824fcbff044d8300
diff --git a/graphics/p5-GD2/files/patch-GD.xs b/graphics/p5-GD2/files/patch-GD.xs
new file mode 100644
index 000000000000..fc34f5f463be
--- /dev/null
+++ b/graphics/p5-GD2/files/patch-GD.xs
@@ -0,0 +1,33 @@
+--- GD.xs.orig Thu Apr 24 07:00:11 2003
++++ GD.xs Wed May 14 17:33:13 2003
+@@ -18,6 +18,30 @@
+ /* Copyright 1995 - 1998, Lincoln D. Stein. See accompanying README file for
+ usage restrictions */
+
++#ifndef PERL_REVISION
++# ifndef __PATCHLEVEL_H_INCLUDED__
++# include "patchlevel.h"
++# endif
++# ifndef PERL_REVISION
++# define PERL_REVISION (5)
++ /* Replace: 1 */
++# define PERL_VERSION PATCHLEVEL
++# define PERL_SUBVERSION SUBVERSION
++ /* Replace PERL_PATCHLEVEL with PERL_VERSION */
++ /* Replace: 0 */
++# endif
++#endif
++
++#if (PERL_VERSION == 5) && (PERL_SUBVERSION==3)
++#ifndef PL_na
++# define PL_na na
++#endif
++
++#ifndef SvPV_nolen
++# define SvPV_nolen(sv) SvPV(sv, PL_na)
++#endif
++#endif /* 5.00503 */
++
+ static int
+ not_here(char *s)
+ {
diff --git a/graphics/p5-GD2/files/patch-aa b/graphics/p5-GD2/files/patch-aa
deleted file mode 100644
index 8bb97191c815..000000000000
--- a/graphics/p5-GD2/files/patch-aa
+++ /dev/null
@@ -1,78 +0,0 @@
---- Makefile.PL.orig Wed Nov 27 16:29:57 2002
-+++ Makefile.PL Sun Apr 13 02:25:57 2003
-@@ -6,46 +6,23 @@
-
-
- # =====> PATHS: CHECK AND ADJUST <=====
--my @INC = qw(-I/usr/local/include -I/usr/local/include/gd);
--my @LIBPATH = qw(-L/usr/lib/X11 -L/usr/X11R6/lib -L/usr/X11/lib -L/usr/local/lib);
--my @LIBS = qw(-lgd -lpng -lz);
--
--if ($^O eq 'VMS'){
-- warn "This is a build on OpenVMS. In case of problems with the build\n";
-- warn "do not bother Lincoln Stein but get in touch with\n";
-- warn "Martin P.J. Zinser (zinser\@decus.de)\n\n";
--
-- if ($ENV{"LIB_ROOT"} eq "") {
-- warn "Define lib_root as a concealed logical pointing to the\n";
-- warn "Top directory where you have your libraries installed\n";
-- warn "E.g. define/job/trans=conc lib_root public$device:[public.util.libs.]\n";
-- warn "Also define the logical pubbin to point to the location\n";
-- warn "of the object libraries\n";
-- warn "Then re-invoke Makefile.PL\n";
-- warn "Exiting now...\n";
-- exit;
-- }
--
-- @INC = qw(-I/lib_root/gd -I/lib_root/libpng -I/lib_root/zlib);
-- @LIBPATH = qw(-Lpubbin);
-- @LIBS = qw(-llibgd.olb -llibpng.olb -llibz.olb);
--}
-+my @INC = qw(-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include -I${X11BASE}/include/X11);
-+my @LIBPATH = qw(-L${LOCALBASE}/lib -L${X11BASE}/lib);
-+my @LIBS = qw(-lfreetype -ljpeg -lgd -lpng -lz);
-
- # path to libgd
- warn "\n";
--my $PREFIX = lc prompt('Where is libgd installed?','/usr/lib');
-+my $PREFIX = "$ENV{LOCALBASE}/lib";
-+
- unless ($PREFIX eq '/usr/lib') {
- $PREFIX =~ s!/lib$!!;
- unshift @INC,"-I$PREFIX/include";
- unshift @LIBPATH,"-L$PREFIX/lib";
- }
-
--# FEATURE FLAGS
--warn "\nPlease choose the features that match how libgd was built:\n";
--
--my $JPEG = lc prompt('Build JPEG support?','y') eq 'y';
--my $FT = lc prompt('Build FreeType support?','y') eq 'y';
--my $XPM = $^O !~ /^freebsd|MSWin32$/ && lc prompt('Build XPM support?','y') eq 'y';
-+$JPEG=1;
-+$FT=1;
-+$XPM=1;
-
- my $FCGI = 0; # set to 1 to build compatability with fastCGI
-
-@@ -61,16 +38,14 @@
- push @INC, '-I/lib_root/ft2/include/freetype' if ($FT && $^O eq 'VMS');
- push @INC, '-I/X11' if ($XPM && $^O eq 'VMS');
-
--# FreeBSD 3.3 with libgd built from ports croaks if -lXpm is specified
--if ($^O ne 'freebsd' && $^O ne 'MSWin32') {
-+if ($^O ne 'MSWin32') {
- push @LIBS,'-lX11','-lXpm' if $XPM;
- }
-
- my $CAPI = defined $ExtUtils::MakeMaker::CAPI_support ? 'TRUE' : 'FALSE';
--my $DEFINES = '';
--$DEFINES .= ' -DHAVE_JPEG' if $JPEG;
--$DEFINES .= ' -DHAVE_FT' if $FT;
--$DEFINES .= ' -DHAVE_XPM' if $XPM;
-+my $DEFINES = '-DHAVE_JPEG -DHAVE_TTF';
-+$DEFINES .= ' -DHAVE_FT' if $FT;
-+$DEFINES .= ' -DHAVE_XPM' unless $^O eq 'MSWin32';
- $DEFINES .= ' -DFCGI' if $FCGI;
-
- WriteMakefile(
diff --git a/graphics/p5-GD2/pkg-plist b/graphics/p5-GD2/pkg-plist
index 383f18c368f0..3c98e9f34dc7 100644
--- a/graphics/p5-GD2/pkg-plist
+++ b/graphics/p5-GD2/pkg-plist
@@ -1,9 +1,9 @@
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/GD.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/GD/Polyline.pm
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/qd.pl
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/GD.bs
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/GD.so
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/autosplit.ix
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/GD
+%%SITE_PERL%%/%%PERL_ARCH%%/GD.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/GD/Polyline.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/GD.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/GD.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/qd.pl
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GD
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/GD