aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-30 21:15:10 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-30 21:15:10 +0800
commit6275bcbb5e7306cc0ab941039f0376bd4f3c227b (patch)
tree11fba5ca53f05a58fd62de6bf28a37c550523536 /graphics
parent770b1343404b6ca40ea4a38ecc2de3e56c78960b (diff)
downloadfreebsd-ports-gnome-6275bcbb5e7306cc0ab941039f0376bd4f3c227b.tar.gz
freebsd-ports-gnome-6275bcbb5e7306cc0ab941039f0376bd4f3c227b.tar.zst
freebsd-ports-gnome-6275bcbb5e7306cc0ab941039f0376bd4f3c227b.zip
Add icon-slicer.
icon-slicer is a utility for generating icon themes and libXcursor cursor themes. The inputs to icon-slicer are conceptually: A) a set of multi-layer images, one for each size B) a XML theme description file Each image contains all the cursors arranged in a grid; for cursors the layers are: - a layer with a dot for the hotspot of each cursor - the main image or first animation frame for multi-frame animated cursors - the second animation frame for multi-frame animated cursors - ... For icons, the layers are: - a layer with the images - an optional layer with attachment points for emblems - an optional layer with boxes for embedding text into icons In practice, since loading of multilayer images is not supported by standard image libraries, each layer is input as a separate image file. The theme description file contains, among other things, information about the source images to read, the location of each named cursor or icon within the grid, and a set of aliases from names to other names. WWW: http://www.freedesktop.org/wiki/Software/icon-slicer
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/icon-slicer/Makefile40
-rw-r--r--graphics/icon-slicer/distinfo2
-rw-r--r--graphics/icon-slicer/pkg-descr33
4 files changed, 76 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 1b8cd9e5072d..a3cfaed68183 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -199,6 +199,7 @@
SUBDIR += hugin
SUBDIR += icoconvert
SUBDIR += icod
+ SUBDIR += icon-slicer
SUBDIR += icontact
SUBDIR += ida
SUBDIR += imageindex
diff --git a/graphics/icon-slicer/Makefile b/graphics/icon-slicer/Makefile
new file mode 100644
index 000000000000..3d46e1e5b524
--- /dev/null
+++ b/graphics/icon-slicer/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: icon-slicer
+# Date created: 29 May 2005
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icon-slicer
+PORTVERSION= 0.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.freedesktop.org/software/icon-slicer/releases/
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= An utility for generating icon and cursor themes
+
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
+
+USE_REINPLACE= yes
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/icon-slicer
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/ s|examples||' ${WRKSRC}/Makefile.in
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in AUTHORS README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/icon-slicer/distinfo b/graphics/icon-slicer/distinfo
new file mode 100644
index 000000000000..a382f4d4daf8
--- /dev/null
+++ b/graphics/icon-slicer/distinfo
@@ -0,0 +1,2 @@
+MD5 (icon-slicer-0.3.tar.gz) = 5c5374d4f265b0abe4daef1d03f87104
+SIZE (icon-slicer-0.3.tar.gz) = 112429
diff --git a/graphics/icon-slicer/pkg-descr b/graphics/icon-slicer/pkg-descr
new file mode 100644
index 000000000000..dd7355195b1f
--- /dev/null
+++ b/graphics/icon-slicer/pkg-descr
@@ -0,0 +1,33 @@
+icon-slicer is a utility for generating icon themes and libXcursor cursor
+themes.
+
+The inputs to icon-slicer are conceptually:
+
+ A) a set of multi-layer images, one for each size
+ B) a XML theme description file
+
+Each image contains all the cursors arranged in a grid; for cursors the
+layers are:
+
+ - a layer with a dot for the hotspot of each cursor
+ - the main image or first animation frame for multi-frame animated cursors
+ - the second animation frame for multi-frame animated cursors
+ - ...
+
+For icons, the layers are:
+
+ - a layer with the images
+ - an optional layer with attachment points for emblems
+ - an optional layer with boxes for embedding text into icons
+
+In practice, since loading of multilayer images is not supported by standard
+image libraries, each layer is input as a separate image file.
+
+The theme description file contains, among other things, information about the
+source images to read, the location of each named cursor or icon within the
+grid, and a set of aliases from names to other names.
+
+WWW: http://www.freedesktop.org/wiki/Software/icon-slicer
+
+- Jean-Yves Lefort
+jylefort@FreeBSD.org