aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-01-21 01:27:58 +0800
committerbf <bf@FreeBSD.org>2012-01-21 01:27:58 +0800
commit69d61cdc11ccfe5104e27d0df5684e91c8832f3e (patch)
tree8cfe64d33af3b756ffd536aa5e3ddae8bf254f65 /graphics
parent851f0ed7aa91bc8f2b2a32f0e3d547361fbc69d4 (diff)
downloadfreebsd-ports-gnome-69d61cdc11ccfe5104e27d0df5684e91c8832f3e.tar.gz
freebsd-ports-gnome-69d61cdc11ccfe5104e27d0df5684e91c8832f3e.tar.zst
freebsd-ports-gnome-69d61cdc11ccfe5104e27d0df5684e91c8832f3e.zip
Use the right toolchain, not lang/gcc34; add a test target
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-PGPLOT/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/p5-PGPLOT/Makefile b/graphics/p5-PGPLOT/Makefile
index a6a630ddad88..57305a955f67 100644
--- a/graphics/p5-PGPLOT/Makefile
+++ b/graphics/p5-PGPLOT/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PGPLOT
PORTVERSION= 2.21
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:KGB
@@ -20,7 +21,7 @@ LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
INSTALL_TARGET= pure_install
SCRIPTS_ENV= PERL=${PERL}
-USE_FORTRAN= g77
+USE_FORTRAN= yes
USE_PERL5= yes
MAN3= PGPLOT.3
@@ -32,4 +33,10 @@ post-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} LICENSE test* ${EXAMPLESDIR}/
.endif
+.if defined(MAINTAINER_MODE) && !defined(BATCH)
+check regression-test test: build
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${_MAKE_JOBS} ${MAKE_ARGS} test
+.endif
+
.include <bsd.port.mk>