aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorxmj <xmj@FreeBSD.org>2015-07-01 13:05:53 +0800
committerxmj <xmj@FreeBSD.org>2015-07-01 13:05:53 +0800
commit6ece209fc886a8683a2fa6e0a572ea5ca8773a40 (patch)
tree6f7923932aa73fbd8865f4156772ea163c0ac220 /graphics
parente5cd8d0de126ae7f91c0610db355ea08ab844e08 (diff)
downloadfreebsd-ports-gnome-6ece209fc886a8683a2fa6e0a572ea5ca8773a40.tar.gz
freebsd-ports-gnome-6ece209fc886a8683a2fa6e0a572ea5ca8773a40.tar.zst
freebsd-ports-gnome-6ece209fc886a8683a2fa6e0a572ea5ca8773a40.zip
graphics/py-pyganim: create port
Pyganim (pronounced like "pig" and "animation") is a Python module for Pygame that makes it easy to add sprite animations to your Pygame game programs. Pyganim works with Python 2 and Python 3. The mascot of Pyganim is a red vitruvian pig. Pyganim was written by Al Sweigart and released under a "Simplified BSD" license. Contact Al with any questions/bug reports: al@inventwithpython.com WWW: http://inventwithpython.com/pyganim Needed by: games/hypatia_engine
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-pyganim/Makefile22
-rw-r--r--graphics/py-pyganim/distinfo2
-rw-r--r--graphics/py-pyganim/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index b3d98cc7754a..45d500c36967 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -803,6 +803,7 @@
SUBDIR += pstoedit
SUBDIR += pstoepsi
SUBDIR += pure-gl
+ SUBDIR += py-pyganim
SUBDIR += py-PyX
SUBDIR += py-PyX12
SUBDIR += py-aafigure
diff --git a/graphics/py-pyganim/Makefile b/graphics/py-pyganim/Makefile
new file mode 100644
index 000000000000..0705822e52d0
--- /dev/null
+++ b/graphics/py-pyganim/Makefile
@@ -0,0 +1,22 @@
+# Created by: Johannes Jost Meixner <xmj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyganim
+PORTVERSION= 0.9.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Pyganim-${PORTVERSION}
+
+MAINTAINER= xmj@FreeBSD.org
+COMMENT= Sprite animation module for Pygame
+
+LICENSE= BSD2CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}game>0:${PORTSDIR}/devel/py-game
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= python zip
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyganim/distinfo b/graphics/py-pyganim/distinfo
new file mode 100644
index 000000000000..5d29f84cec59
--- /dev/null
+++ b/graphics/py-pyganim/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Pyganim-0.9.0.zip) = c09138feaa40f700ab2e6139e3c3e09c98b8842fccbf9648244aee07cfaeb491
+SIZE (Pyganim-0.9.0.zip) = 292917
diff --git a/graphics/py-pyganim/pkg-descr b/graphics/py-pyganim/pkg-descr
new file mode 100644
index 000000000000..cf04c4302f90
--- /dev/null
+++ b/graphics/py-pyganim/pkg-descr
@@ -0,0 +1,10 @@
+Pyganim (pronounced like "pig" and "animation") is a Python module for Pygame
+that makes it easy to add sprite animations to your Pygame game programs.
+Pyganim works with Python 2 and Python 3.
+
+The mascot of Pyganim is a red vitruvian pig.
+
+Pyganim was written by Al Sweigart and released under a "Simplified BSD"
+license. Contact Al with any questions/bug reports: al@inventwithpython.com
+
+WWW: http://inventwithpython.com/pyganim