aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2015-06-15 04:23:09 +0800
committerale <ale@FreeBSD.org>2015-06-15 04:23:09 +0800
commit7a05b2109bac60edd8c5fc348cd7e68f224adc70 (patch)
treeb8c573ce6049050a5e508f246162c0175bc8a1b6 /graphics
parentd19271f843fe9139d32764b1362910667151b94b (diff)
downloadfreebsd-ports-gnome-7a05b2109bac60edd8c5fc348cd7e68f224adc70.tar.gz
freebsd-ports-gnome-7a05b2109bac60edd8c5fc348cd7e68f224adc70.tar.zst
freebsd-ports-gnome-7a05b2109bac60edd8c5fc348cd7e68f224adc70.zip
Update PHP ports:
- php5 to 5.4.42 - php55 to 5.5.26 - php56 to 5.6.10
Diffstat (limited to 'graphics')
-rw-r--r--graphics/php55-gd/Makefile1
-rw-r--r--graphics/php55-gd/files/patch-libgd_webpimg.c29
-rw-r--r--graphics/php56-gd/Makefile1
-rw-r--r--graphics/php56-gd/files/patch-libgd_webpimg.c29
4 files changed, 0 insertions, 60 deletions
diff --git a/graphics/php55-gd/Makefile b/graphics/php55-gd/Makefile
index 624b80b64de9..6d549ce17dce 100644
--- a/graphics/php55-gd/Makefile
+++ b/graphics/php55-gd/Makefile
@@ -1,7 +1,6 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php55
diff --git a/graphics/php55-gd/files/patch-libgd_webpimg.c b/graphics/php55-gd/files/patch-libgd_webpimg.c
deleted file mode 100644
index d1d74cd0e7a6..000000000000
--- a/graphics/php55-gd/files/patch-libgd_webpimg.c
+++ /dev/null
@@ -1,29 +0,0 @@
-Adjust to libvpx 1.4.0 until the code is removed.
-
-https://chromium.googlesource.com/webm/libvpx/+/9cdaa3d%5E!/
-https://bitbucket.org/libgd/gd-libgd/commits/824a3aa
-
---- libgd/webpimg.c.orig 2013-06-25 09:58:23 UTC
-+++ libgd/webpimg.c
-@@ -711,14 +711,14 @@ static WebPResult VPXEncode(const uint8*
- codec_ctl(&enc, VP8E_SET_STATIC_THRESHOLD, 0);
- codec_ctl(&enc, VP8E_SET_TOKEN_PARTITIONS, 2);
-
-- vpx_img_wrap(&img, IMG_FMT_I420,
-+ vpx_img_wrap(&img, VPX_IMG_FMT_I420,
- y_width, y_height, 16, (uint8*)(Y));
-- img.planes[PLANE_Y] = (uint8*)(Y);
-- img.planes[PLANE_U] = (uint8*)(U);
-- img.planes[PLANE_V] = (uint8*)(V);
-- img.stride[PLANE_Y] = y_stride;
-- img.stride[PLANE_U] = uv_stride;
-- img.stride[PLANE_V] = uv_stride;
-+ img.planes[VPX_PLANE_Y] = (uint8*)(Y);
-+ img.planes[VPX_PLANE_U] = (uint8*)(U);
-+ img.planes[VPX_PLANE_V] = (uint8*)(V);
-+ img.stride[VPX_PLANE_Y] = y_stride;
-+ img.stride[VPX_PLANE_U] = uv_stride;
-+ img.stride[VPX_PLANE_V] = uv_stride;
-
- res = vpx_codec_encode(&enc, &img, 0, 1, 0, VPX_DL_BEST_QUALITY);
-
diff --git a/graphics/php56-gd/Makefile b/graphics/php56-gd/Makefile
index 4979a92bb137..4746215748f7 100644
--- a/graphics/php56-gd/Makefile
+++ b/graphics/php56-gd/Makefile
@@ -1,7 +1,6 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= graphics
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/graphics/php56-gd/files/patch-libgd_webpimg.c b/graphics/php56-gd/files/patch-libgd_webpimg.c
deleted file mode 100644
index d1d74cd0e7a6..000000000000
--- a/graphics/php56-gd/files/patch-libgd_webpimg.c
+++ /dev/null
@@ -1,29 +0,0 @@
-Adjust to libvpx 1.4.0 until the code is removed.
-
-https://chromium.googlesource.com/webm/libvpx/+/9cdaa3d%5E!/
-https://bitbucket.org/libgd/gd-libgd/commits/824a3aa
-
---- libgd/webpimg.c.orig 2013-06-25 09:58:23 UTC
-+++ libgd/webpimg.c
-@@ -711,14 +711,14 @@ static WebPResult VPXEncode(const uint8*
- codec_ctl(&enc, VP8E_SET_STATIC_THRESHOLD, 0);
- codec_ctl(&enc, VP8E_SET_TOKEN_PARTITIONS, 2);
-
-- vpx_img_wrap(&img, IMG_FMT_I420,
-+ vpx_img_wrap(&img, VPX_IMG_FMT_I420,
- y_width, y_height, 16, (uint8*)(Y));
-- img.planes[PLANE_Y] = (uint8*)(Y);
-- img.planes[PLANE_U] = (uint8*)(U);
-- img.planes[PLANE_V] = (uint8*)(V);
-- img.stride[PLANE_Y] = y_stride;
-- img.stride[PLANE_U] = uv_stride;
-- img.stride[PLANE_V] = uv_stride;
-+ img.planes[VPX_PLANE_Y] = (uint8*)(Y);
-+ img.planes[VPX_PLANE_U] = (uint8*)(U);
-+ img.planes[VPX_PLANE_V] = (uint8*)(V);
-+ img.stride[VPX_PLANE_Y] = y_stride;
-+ img.stride[VPX_PLANE_U] = uv_stride;
-+ img.stride[VPX_PLANE_V] = uv_stride;
-
- res = vpx_codec_encode(&enc, &img, 0, 1, 0, VPX_DL_BEST_QUALITY);
-