aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-05-27 19:32:02 +0800
committerstas <stas@FreeBSD.org>2009-05-27 19:32:02 +0800
commit7b001362b9797c59f1eaf23aac6f5b874987a9e5 (patch)
tree954b4687435c878d05876a42c0085678344fd1ed /graphics
parent83a4f4508c8c3510c228fdd48be3cb6101be86d9 (diff)
downloadfreebsd-ports-gnome-7b001362b9797c59f1eaf23aac6f5b874987a9e5.tar.gz
freebsd-ports-gnome-7b001362b9797c59f1eaf23aac6f5b874987a9e5.tar.zst
freebsd-ports-gnome-7b001362b9797c59f1eaf23aac6f5b874987a9e5.zip
- Use OPTIONS.
- Add lensfun support [1]. - Bump portrevision. PR: ports/134924 [1] Submitted by: Denis Barov <dindin@dindin.ru> [1]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ufraw/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 7ea38989f935..7f535ac44531 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ufraw
PORTVERSION= 0.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= SF
@@ -30,20 +30,30 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CPPFLAGS= -I${LOCALBASE}/include
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ARGS= --enable-mime
-
PC_FALSE+= cinepaint
-.ifndef WITHOUT_EXIV2
+
+OPTIONS= EXIV2 "EXIF support via exiv2 library" on \
+ GIMP "Install GIMP UFRaw plugin" on \
+ LENSFUN "Build with LenFun library support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_EXIV2)
LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
.else
PC_FALSE+= exiv2
.endif
-.ifndef WITHOUT_GIMP
+.if !defined(WITHOUT_GIMP)
LIB_DEPENDS+= gimp-2.0.0:${PORTSDIR}/graphics/gimp-app
PLIST_SUB+= GIMP=""
.else
PC_FALSE+= gimp
PLIST_SUB+= GIMP="@comment "
.endif
+.if !defined(WITHOUT_LENSFUN)
+LIB_DEPENDS+= lensfun.0:${PORTSDIR}/graphics/lensfun
+CONFIGURE_ARGS+= --with-lensfun
+.endif
MAN1= ufraw.1
@@ -54,4 +64,4 @@ post-patch:
@${REINPLACE_CMD} -e '/PKG_CONFIG.*$i/s|$$PKG_CONFIG|${FALSE}|' ${WRKSRC}/configure
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>