aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-07-23 03:54:58 +0800
committerahze <ahze@FreeBSD.org>2006-07-23 03:54:58 +0800
commit7b687fa0db7bded5e2dfc9de56a35caaf1ec4131 (patch)
treed8db234b282d91b8bf42672fc30a6048d1bd54ea /graphics
parent6570cb2dae31c8834a1d72694af21ea24c2f5288 (diff)
downloadfreebsd-ports-gnome-7b687fa0db7bded5e2dfc9de56a35caaf1ec4131.tar.gz
freebsd-ports-gnome-7b687fa0db7bded5e2dfc9de56a35caaf1ec4131.tar.zst
freebsd-ports-gnome-7b687fa0db7bded5e2dfc9de56a35caaf1ec4131.zip
- Fix build on sparc64
PR: 99897 Submitted by: ahze (me) Approved by: maintainer (14 days timeout)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/blender-devel/Makefile4
-rw-r--r--graphics/blender-devel/files/patch-source_blender_blenlib_intern_storage.c20
2 files changed, 20 insertions, 4 deletions
diff --git a/graphics/blender-devel/Makefile b/graphics/blender-devel/Makefile
index 3401b180e89d..fd2b3182346a 100644
--- a/graphics/blender-devel/Makefile
+++ b/graphics/blender-devel/Makefile
@@ -33,10 +33,6 @@ CFLAGS+= -O3 -ffast-math
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64"
-.endif
-
pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${ECHO_MSG} "You can enable additional compilation optimizations"
diff --git a/graphics/blender-devel/files/patch-source_blender_blenlib_intern_storage.c b/graphics/blender-devel/files/patch-source_blender_blenlib_intern_storage.c
new file mode 100644
index 000000000000..d85e50769d3e
--- /dev/null
+++ b/graphics/blender-devel/files/patch-source_blender_blenlib_intern_storage.c
@@ -0,0 +1,20 @@
+--- source/blender/blenlib/intern/storage.c.orig Fri Jul 7 14:15:04 2006
++++ source/blender/blenlib/intern/storage.c Fri Jul 7 14:17:47 2006
+@@ -50,7 +50,7 @@
+ #include <time.h>
+ #include <sys/stat.h>
+
+-#if !defined(linux) && (defined(__sgi) || defined(__sun__) || defined(__sun) || defined(__sparc) || defined(__sparc__))
++#if !defined(__FreeBSD__) && !defined(linux) && (defined(__sgi) || defined(__sun__) || defined(__sun) || defined(__sparc) || defined(__sparc__))
+ #include <sys/statfs.h>
+ #endif
+
+@@ -194,7 +194,7 @@
+ #ifdef __BeOS
+ return -1;
+ #endif
+-#if !defined(linux) && (defined (__sgi) || defined (__sun__) || defined (__sun) || defined(__sparc) || defined(__sparc__))
++#if !defined(__FreeBSD__) && !defined(linux) && (defined (__sgi) || defined (__sun__) || defined (__sun) || defined(__sparc) || defined(__sparc__))
+
+ if (statfs(name, &disk, sizeof(struct statfs), 0)){
+ /* printf("diskfree: Couldn't get information about %s.\n",dir); */