aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgrog <grog@FreeBSD.org>2015-11-23 10:47:23 +0800
committergrog <grog@FreeBSD.org>2015-11-23 10:47:23 +0800
commit7bf5a7504f1d7557f571329ba3b53ee2347d2f2a (patch)
tree5c1b37ae83ac68a7f2ddc5369d28853b141eb94c /graphics
parent293b426d35dbc26fbb7f8e4fc14946bf0c1ab9dc (diff)
downloadfreebsd-ports-gnome-7bf5a7504f1d7557f571329ba3b53ee2347d2f2a.tar.gz
freebsd-ports-gnome-7bf5a7504f1d7557f571329ba3b53ee2347d2f2a.tar.zst
freebsd-ports-gnome-7bf5a7504f1d7557f571329ba3b53ee2347d2f2a.zip
Add missing dependency.
Add missing files to pkg-plist. Work around breakage in configuration files. Reviewed by: Callum Gibson, Henrik Johansson Approved by: edwin@ (mentor) MFC after: 2 weeks
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hugin/Makefile3
-rw-r--r--graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt11
-rw-r--r--graphics/hugin/pkg-plist3
3 files changed, 16 insertions, 1 deletions
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 32f7e9db442f..953da0f46d86 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hugin
PORTVERSION= 2015.0.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -16,6 +16,7 @@ LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libexiv2.so:${PORTSDIR}/graphics/exiv2 \
liblensfun.so:${PORTSDIR}/graphics/lensfun \
libpano13.so:${PORTSDIR}/graphics/libpano13 \
+ libvigraimpex.so:${PORTSDIR}/graphics/vigra \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20 \
diff --git a/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt b/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt
new file mode 100644
index 000000000000..12cd0788f1df
--- /dev/null
+++ b/graphics/hugin/files/patch-src__hugin_script_interface__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/hugin_script_interface/CMakeLists.txt~ 2015-07-18 02:44:01.000000000 +1000
++++ src/hugin_script_interface/CMakeLists.txt 2015-11-23 13:02:39.000000000 +1100
+@@ -201,7 +201,7 @@
+ # Linux/MacOS
+ # install Python related files into folder depending on used Python version
+
+- EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))"
++ EXECUTE_PROCESS( COMMAND ${PYTHON_EXECUTABLE} -c "import string; from distutils.sysconfig import get_python_lib; print(string.replace (get_python_lib(1), \"/usr/local/\", \"\"))"
+ OUTPUT_VARIABLE pyinstalldir
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+
diff --git a/graphics/hugin/pkg-plist b/graphics/hugin/pkg-plist
index 77a55f7727d1..a3a525ba2b21 100644
--- a/graphics/hugin/pkg-plist
+++ b/graphics/hugin/pkg-plist
@@ -671,3 +671,6 @@ share/locale/zh_TW/LC_MESSAGES/hugin.mo
share/mime/packages/hugin.xml
share/pixmaps/hugin.png
share/pixmaps/ptbatcher.png
+share/appdata/PTBatcherGUI.appdata.xml
+share/appdata/calibrate_lens_gui.appdata.xml
+share/appdata/hugin.appdata.xml