aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2017-01-30 03:22:47 +0800
committermarino <marino@FreeBSD.org>2017-01-30 03:22:47 +0800
commit837c6a43832f3f417ce51ce3eb3ed390afc82249 (patch)
treee42a4a92d9c7033089035d50b4e88156c8e6c3c4 /graphics
parent40026fd929da95c75e365ec5068a1cf8c6e4d2b1 (diff)
downloadfreebsd-ports-gnome-837c6a43832f3f417ce51ce3eb3ed390afc82249.tar.gz
freebsd-ports-gnome-837c6a43832f3f417ce51ce3eb3ed390afc82249.tar.zst
freebsd-ports-gnome-837c6a43832f3f417ce51ce3eb3ed390afc82249.zip
graphics/rawtherapee(-devel): Fix OSVERSION, use with OPSYS
The OSVERSION for FreeBSD 10.3 is 1003000, not 1030000. The last commit blocked FreeBSD 10.3 too. OSVERSION is also supposed to be used in conjunction with OPSYS. Approved by: just-fix-it
Diffstat (limited to 'graphics')
-rw-r--r--graphics/rawtherapee-devel/Makefile4
-rw-r--r--graphics/rawtherapee/Makefile4
2 files changed, 6 insertions, 2 deletions
diff --git a/graphics/rawtherapee-devel/Makefile b/graphics/rawtherapee-devel/Makefile
index 1e3469bc31c8..bbcf0e8d8e3f 100644
--- a/graphics/rawtherapee-devel/Makefile
+++ b/graphics/rawtherapee-devel/Makefile
@@ -76,7 +76,8 @@ OPTIMIZED_CFLAGS_CFLAGS= -O3 -funroll-loops -msse2
# -------------------------------------------------------------------
#
-.if ${OSVERSION} < 1030000
+.if ${OPSYS} == FreeBSD
+.if ${OSVERSION} < 1003000
IGNORE= is only for supported FreeBSD releases
.endif
@@ -87,6 +88,7 @@ IGNORE= is only for supported FreeBSD releases
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON=Only amd64 is supported on non-released FreeBSD versions.
.endif
+.endif
.if ${PORT_OPTIONS:MNATIVE}
CMAKE_ARGS+= -DPROC_TARGET_NUMBER="2"
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 19cd48cd740f..017a5585c3d1 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -74,7 +74,8 @@ OPTIMIZED_CFLAGS_CFLAGS= -O3 -funroll-loops -msse2
# -------------------------------------------------------------------
#
-.if ${OSVERSION} < 1030000
+.if ${OPSYS} == FreeBSD
+.if ${OSVERSION} < 1003000
IGNORE= is only for supported FreeBSD releases
.endif
@@ -85,6 +86,7 @@ IGNORE= is only for supported FreeBSD releases
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON=Only amd64 is supported on non-released FreeBSD versions.
.endif
+.endif
.if ${PORT_OPTIONS:MNATIVE}
CMAKE_ARGS+= -DPROC_TARGET_NUMBER="2"