aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-01-18 17:37:49 +0800
committermva <mva@FreeBSD.org>2014-01-18 17:37:49 +0800
commit860bd328561ecfbd64bfc8fc7bb81ebcfd1d5732 (patch)
treeee7a59f412d1125ac63e7763e3b3d12aba17b462 /graphics
parenta1ef33b5e724ac9774f8aa3129ccced27a0cdc37 (diff)
downloadfreebsd-ports-gnome-860bd328561ecfbd64bfc8fc7bb81ebcfd1d5732.tar.gz
freebsd-ports-gnome-860bd328561ecfbd64bfc8fc7bb81ebcfd1d5732.tar.zst
freebsd-ports-gnome-860bd328561ecfbd64bfc8fc7bb81ebcfd1d5732.zip
- Enable stagedir support
- Convert to new LIB_DEPENDS - Add missing x11 dependency - Convert to new OPTIONS framework - Add LICENSE
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sdl_ttf/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
index 4265e70c7966..f840f8cd0794 100644
--- a/graphics/sdl_ttf/Makefile
+++ b/graphics/sdl_ttf/Makefile
@@ -8,25 +8,29 @@ MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
DISTNAME= SDL_ttf-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
-COMMENT= A library to use TrueType fonts to render text in SDL applications
+COMMENT= Library to use TrueType fonts to render text in SDL applications
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LICENSE= ZLIB
+
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
USE_AUTOTOOLS= libtool
USE_SDL= sdl
USES= gmake pathfix pkgconfig
+USE_XORG= x11
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-.if !defined(WITHOUT_X11) && !defined(WITHOUT_GL)
-USE_GL= yes
-.endif
+OPTIONS_DEFINE= OPENGL
+OPTIONS_DEFAULT= OPENGL
+
+OPENGL_USE= GL=yes
-NO_STAGE= yes
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/.libs/showfont ${PREFIX}/bin/sdl-showfont
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/showfont \
+ ${STAGEDIR}${PREFIX}/bin/sdl-showfont
.include <bsd.port.mk>