aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-07-27 18:22:26 +0800
committertcberner <tcberner@FreeBSD.org>2016-07-27 18:22:26 +0800
commit861bf1ebf67ed1943dd3aff0f06fbcc0af06907b (patch)
tree374c9354fb2abed4f073fc779090ab725081022a /graphics
parent88e15504d66f134162faf2e02a58fe3d9aa389b9 (diff)
downloadfreebsd-ports-gnome-861bf1ebf67ed1943dd3aff0f06fbcc0af06907b.tar.gz
freebsd-ports-gnome-861bf1ebf67ed1943dd3aff0f06fbcc0af06907b.tar.zst
freebsd-ports-gnome-861bf1ebf67ed1943dd3aff0f06fbcc0af06907b.zip
Update graphics/exiv2 to 0.25.
As there is an shlib version bump, bump them portrevision of dependent ports. While doing so, also switch to the cmake build system, as it requires less patching and is easier to handle. PR: 211329 Reviewed by: mat, rakuco, kwm Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D7283
Diffstat (limited to 'graphics')
-rw-r--r--graphics/darktable/Makefile1
-rw-r--r--graphics/exiv2/Makefile29
-rw-r--r--graphics/exiv2/distinfo5
-rw-r--r--graphics/exiv2/files/patch-src-Makefile20
-rw-r--r--graphics/exiv2/files/patch-src_CMakeLists.txt22
-rw-r--r--graphics/exiv2/pkg-plist19
-rw-r--r--graphics/geeqie/Makefile1
-rw-r--r--graphics/gegl/Makefile2
-rw-r--r--graphics/gexiv2/Makefile2
-rw-r--r--graphics/gimp-lensfun-plugin/Makefile2
-rw-r--r--graphics/gnome-color-manager/Makefile2
-rw-r--r--graphics/gthumb/Makefile1
-rw-r--r--graphics/gwenview-kde4/Makefile1
-rw-r--r--graphics/hugin/Makefile2
-rw-r--r--graphics/kphotoalbum-kde4/Makefile2
-rw-r--r--graphics/libkexiv2-kde4/Makefile2
-rw-r--r--graphics/luminance-qt5/Makefile2
-rw-r--r--graphics/luminance/Makefile2
-rw-r--r--graphics/nomacs/Makefile2
-rw-r--r--graphics/oyranos/Makefile2
-rw-r--r--graphics/phototonic/Makefile1
-rw-r--r--graphics/py-exiv2/Makefile2
-rw-r--r--graphics/rawstudio/Makefile2
-rw-r--r--graphics/shotwell/Makefile1
-rw-r--r--graphics/ufraw/Makefile2
-rw-r--r--graphics/viewnior/Makefile1
26 files changed, 69 insertions, 61 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 5eefcd75d9a0..fad57a24ceb8 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -3,6 +3,7 @@
PORTNAME= darktable
PORTVERSION= 2.0.4
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= https://github.com/darktable-org/${PORTNAME}/releases/download/release-${PORTVERSION:C/\.rc/rc/}/
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index 20751cfd7754..b19fa640c71e 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= exiv2
-PORTVERSION= 0.24
-PORTREVISION= 2
+PORTVERSION= 0.25
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://www.exiv2.org/
@@ -16,29 +15,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:textproc/expat2
-GNU_CONFIGURE= yes
-USES= cpe gettext gmake iconv libtool
+USES= cmake:outsource cpe gettext iconv pathfix
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE=yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CMAKE_ARGS= -DEXIV2_ENABLE_VIDEO:BOOL=TRUE \
+ -DEXIV2_ENABLE_BUILD_PO:BOOL=TRUE \
+ -DEXIV2_ENABLE_BUILD_SAMPLES:BOOL=FALSE
-.include <bsd.port.options.mk>
+PATHFIX_CMAKELISTSTXT= CMakeChecks.txt
-.if ${ARCH} == powerpc64
-CFLAGS+= -mminimal-toc
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's,LDFLAGS -no-undefined -lpsapi",& ;; \
- dragonfly* | freebsd*),' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's,(libdir)/pkgconfig,(prefix)/libdata/pkgconfig,' \
- ${WRKSRC}/src/Makefile
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/exiv2 \
- ${STAGEDIR}${PREFIX}/lib/libexiv2.so.13
+CFLAGS_powerpc64= -mminimal-toc
.include <bsd.port.mk>
diff --git a/graphics/exiv2/distinfo b/graphics/exiv2/distinfo
index 76265048025f..c9fb070b8ede 100644
--- a/graphics/exiv2/distinfo
+++ b/graphics/exiv2/distinfo
@@ -1,2 +1,3 @@
-SHA256 (exiv2-0.24.tar.gz) = f4a443e6c7fb9d9f5e787732f76969a64c72c4c04af69b10ed57f949c2dfef8e
-SIZE (exiv2-0.24.tar.gz) = 4635028
+TIMESTAMP = 1469188288
+SHA256 (exiv2-0.25.tar.gz) = c80bfc778a15fdb06f71265db2c3d49d8493c382e516cb99b8c9f9cbde36efa4
+SIZE (exiv2-0.25.tar.gz) = 5434325
diff --git a/graphics/exiv2/files/patch-src-Makefile b/graphics/exiv2/files/patch-src-Makefile
deleted file mode 100644
index 062b490b2d70..000000000000
--- a/graphics/exiv2/files/patch-src-Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/Makefile.orig 2013-12-01 12:13:42 UTC
-+++ src/Makefile
-@@ -215,7 +215,7 @@ ifdef DEP_TRACKING
- endif
-
- # Be sure to rewrite exv_conf.h before compiling anything
--$(SRC): exv_conf.h
-+$(SRC) $(EXIV2SRC): exv_conf.h
-
- exv_conf.h: $(top_srcdir)/config/config.h
- LC_ALL=C sed 's/#define \([A-Z]\)/#define EXV_\1/; s/#undef \([A-Z]\)/#undef EXV_\1/' < $< > $@
-@@ -231,7 +231,7 @@ lib: $(OBJ)
-
- $(EXIV2BIN): lib $(EXIV2OBJ) $(EXIV2COBJ)
- -mkdir ../bin >/dev/null 2>&1
-- @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $(EXIV2OBJ) $(EXIV2COBJ) -rpath $(libdir)
-+ @$(LIBTOOL) --mode=link $(LINK.cc) -o $@ $(LIBRARY) $(EXIV2OBJ) $(EXIV2COBJ) -rpath $(libdir) $(LIBS)
-
- install-header:
- $(INSTALL_DIRS) $(DESTDIR)$(incdir)
diff --git a/graphics/exiv2/files/patch-src_CMakeLists.txt b/graphics/exiv2/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..e72a9605a124
--- /dev/null
+++ b/graphics/exiv2/files/patch-src_CMakeLists.txt
@@ -0,0 +1,22 @@
+FreeBSD does hat have -ldl.
+
+Instead of unconditionally passing 'dl' to the linker, use cmakes 'CMAKE_DL_LIBS' [1]
+which handles that properly on all systems.
+
+[1] https://cmake.org/cmake/help/v3.6/variable/CMAKE_DL_LIBS.html
+
+--- src/CMakeLists.txt.orig 2016-07-23 14:00:07 UTC
++++ src/CMakeLists.txt
+@@ -247,9 +247,9 @@ if ( MSVC )
+ TARGET_LINK_LIBRARIES( exiv2lib ${SSH_LIBRARIES} )
+ else()
+ if ( NOT MINGW )
+- TARGET_LINK_LIBRARIES( exiv2lib dl ${EXPAT_LIBRARIES} )
+- TARGET_LINK_LIBRARIES( exiv2lib dl ${CURL_LIBRARIES} )
+- TARGET_LINK_LIBRARIES( exiv2lib dl ${SSH_LIBRARIES} )
++ TARGET_LINK_LIBRARIES( exiv2lib ${CMAKE_DL_LIBS} ${EXPAT_LIBRARIES} )
++ TARGET_LINK_LIBRARIES( exiv2lib ${CMAKE_DL_LIBS} ${CURL_LIBRARIES} )
++ TARGET_LINK_LIBRARIES( exiv2lib ${CMAKE_DL_LIBS} ${SSH_LIBRARIES} )
+ else()
+ TARGET_LINK_LIBRARIES( exiv2lib ${EXPAT_LIBRARIES} )
+ TARGET_LINK_LIBRARIES( exiv2lib ${CURL_LIBRARIES} )
diff --git a/graphics/exiv2/pkg-plist b/graphics/exiv2/pkg-plist
index a566d63d42c6..40f2d79154e1 100644
--- a/graphics/exiv2/pkg-plist
+++ b/graphics/exiv2/pkg-plist
@@ -2,6 +2,7 @@ bin/exiv2
include/exiv2/asfvideo.hpp
include/exiv2/basicio.hpp
include/exiv2/bmpimage.hpp
+include/exiv2/config.h
include/exiv2/convert.hpp
include/exiv2/cr2image.hpp
include/exiv2/crwimage.hpp
@@ -12,8 +13,10 @@ include/exiv2/error.hpp
include/exiv2/exif.hpp
include/exiv2/exiv2.hpp
include/exiv2/exv_conf.h
+include/exiv2/exv_msvc.h
include/exiv2/futils.hpp
include/exiv2/gifimage.hpp
+include/exiv2/http.hpp
include/exiv2/image.hpp
include/exiv2/iptc.hpp
include/exiv2/jp2image.hpp
@@ -31,24 +34,34 @@ include/exiv2/quicktimevideo.hpp
include/exiv2/rafimage.hpp
include/exiv2/riffvideo.hpp
include/exiv2/rw2image.hpp
+include/exiv2/svn_version.h
include/exiv2/tags.hpp
include/exiv2/tgaimage.hpp
include/exiv2/tiffimage.hpp
include/exiv2/types.hpp
+include/exiv2/utilsvideo.hpp
include/exiv2/value.hpp
include/exiv2/version.hpp
include/exiv2/xmp.hpp
include/exiv2/xmpsidecar.hpp
-lib/libexiv2.a
lib/libexiv2.so
-lib/libexiv2.so.13
-lib/libexiv2.so.13.0.0
+lib/libexiv2.so.14
+lib/libexiv2.so.14.0.0
+libdata/pkgconfig/exiv2.lsm
libdata/pkgconfig/exiv2.pc
man/man1/exiv2.1.gz
+share/locale/bs/LC_MESSAGES/exiv2.mo
share/locale/de/LC_MESSAGES/exiv2.mo
share/locale/es/LC_MESSAGES/exiv2.mo
share/locale/fi/LC_MESSAGES/exiv2.mo
share/locale/fr/LC_MESSAGES/exiv2.mo
+share/locale/gl/LC_MESSAGES/exiv2.mo
+share/locale/ms/LC_MESSAGES/exiv2.mo
share/locale/pl/LC_MESSAGES/exiv2.mo
+share/locale/pt/LC_MESSAGES/exiv2.mo
share/locale/ru/LC_MESSAGES/exiv2.mo
share/locale/sk/LC_MESSAGES/exiv2.mo
+share/locale/sv/LC_MESSAGES/exiv2.mo
+share/locale/ug/LC_MESSAGES/exiv2.mo
+share/locale/uk/LC_MESSAGES/exiv2.mo
+share/locale/vi/LC_MESSAGES/exiv2.mo
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 0e6ab7e9c912..2595b42398e6 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -3,6 +3,7 @@
PORTNAME= geeqie
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.geeqie.org/
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 5b505d85640d..80aba41de0ab 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gegl
PORTVERSION= 0.2.0
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= graphics
MASTER_SITES= GIMP
diff --git a/graphics/gexiv2/Makefile b/graphics/gexiv2/Makefile
index 0d5a0d56a290..6c9b19f4fd5b 100644
--- a/graphics/gexiv2/Makefile
+++ b/graphics/gexiv2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gexiv2
PORTVERSION= 0.6.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= http://pkgs.fedoraproject.org/repo/pkgs/libgexiv2/libgexiv2_0.6.1.tar.xz/5bd2ba92b765a2b3721874ebd2647734/
DISTNAME= lib${PORTNAME}_${PORTVERSION}
diff --git a/graphics/gimp-lensfun-plugin/Makefile b/graphics/gimp-lensfun-plugin/Makefile
index 466c3b1f7c7b..6c8d7a3016ae 100644
--- a/graphics/gimp-lensfun-plugin/Makefile
+++ b/graphics/gimp-lensfun-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lensfun
DISTVERSION= 0.2.4-dev
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
PKGNAMEPREFIX= gimp-
PKGNAMESUFFIX= -plugin
diff --git a/graphics/gnome-color-manager/Makefile b/graphics/gnome-color-manager/Makefile
index 682f1c5e7a59..ed1a6e46fef8 100644
--- a/graphics/gnome-color-manager/Makefile
+++ b/graphics/gnome-color-manager/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnome-color-manager
PORTVERSION= 3.18.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index 863f56e64211..c87e55d36021 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -4,6 +4,7 @@
PORTNAME= gthumb
PORTVERSION= 3.4.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
diff --git a/graphics/gwenview-kde4/Makefile b/graphics/gwenview-kde4/Makefile
index 1f46839ba657..61a52103b941 100644
--- a/graphics/gwenview-kde4/Makefile
+++ b/graphics/gwenview-kde4/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gwenview
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index aad459f0ff6c..fb3d0c7b6d93 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hugin
PORTVERSION= 2016.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
diff --git a/graphics/kphotoalbum-kde4/Makefile b/graphics/kphotoalbum-kde4/Makefile
index 63cf0dd696b5..2e5cb81256eb 100644
--- a/graphics/kphotoalbum-kde4/Makefile
+++ b/graphics/kphotoalbum-kde4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kphotoalbum
PORTVERSION= 4.4
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
DIST_SUBDIR= KDE
diff --git a/graphics/libkexiv2-kde4/Makefile b/graphics/libkexiv2-kde4/Makefile
index 8af321637367..b4b712c41175 100644
--- a/graphics/libkexiv2-kde4/Makefile
+++ b/graphics/libkexiv2-kde4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libkexiv2
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index 92ca40e325f9..6aaf5612f503 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= luminance-hdr
DISTVERSION= 2.4.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
PKGNAMESUFFIX= -qt5
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index 59069f80e62a..e29b4ba3c25a 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -3,7 +3,7 @@
PORTNAME= luminance-hdr
DISTVERSION= 2.3.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
diff --git a/graphics/nomacs/Makefile b/graphics/nomacs/Makefile
index 809b49278e3a..312227d08f91 100644
--- a/graphics/nomacs/Makefile
+++ b/graphics/nomacs/Makefile
@@ -2,7 +2,7 @@
PORTNAME= nomacs
PORTVERSION= 2.2.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= SF/nomacs/nomacs-${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
diff --git a/graphics/oyranos/Makefile b/graphics/oyranos/Makefile
index 94bfe046224a..5937a6cd52d6 100644
--- a/graphics/oyranos/Makefile
+++ b/graphics/oyranos/Makefile
@@ -2,7 +2,7 @@
PORTNAME= oyranos
PORTVERSION= 0.9.5
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Oyranos/Oyranos%20${PORTVERSION:C|(.*)\.[0-9]*$|\1|}
diff --git a/graphics/phototonic/Makefile b/graphics/phototonic/Makefile
index 0fd95529ac20..ba452efbcbf9 100644
--- a/graphics/phototonic/Makefile
+++ b/graphics/phototonic/Makefile
@@ -4,6 +4,7 @@
PORTNAME= phototonic
PORTVERSION= 1.7.20
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= olivierd@FreeBSD.org
diff --git a/graphics/py-exiv2/Makefile b/graphics/py-exiv2/Makefile
index 4eb786058a3c..39da0a5395d2 100644
--- a/graphics/py-exiv2/Makefile
+++ b/graphics/py-exiv2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= exiv2
PORTVERSION= 0.3.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics python
MASTER_SITES= https://launchpadlibrarian.net/83595798/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/graphics/rawstudio/Makefile b/graphics/rawstudio/Makefile
index 409b1c1ef158..d491f0b7fed2 100644
--- a/graphics/rawstudio/Makefile
+++ b/graphics/rawstudio/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rawstudio
PORTVERSION= 2.0
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= graphics
MASTER_SITES= http://rawstudio.org/files/release/
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index eaac87cc8c0a..4f9ead606c7e 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -3,6 +3,7 @@
PORTNAME= shotwell
PORTVERSION= 0.23.2
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= GNOME/sources/shotwell/${PORTVERSION:R}
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 92f37809deea..e7e101a41627 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ufraw
PORTVERSION= 0.22
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/graphics/viewnior/Makefile b/graphics/viewnior/Makefile
index ea278835b0f9..a8294ad1f10e 100644
--- a/graphics/viewnior/Makefile
+++ b/graphics/viewnior/Makefile
@@ -4,6 +4,7 @@
PORTNAME= viewnior
PORTVERSION= 1.6
DISTVERSIONPREFIX= ${PORTNAME}-
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= nemysis@FreeBSD.org