aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-06-06 19:34:58 +0800
committermadpilot <madpilot@FreeBSD.org>2012-06-06 19:34:58 +0800
commit88ae9efc3a621d8a1021a9f7f712e376f7917a34 (patch)
tree5ece30879f3d52b188eed857603dbdd92cda8dd8 /graphics
parent5540f2a0ea1f938dbcf9addd9f80de6bf349371a (diff)
downloadfreebsd-ports-gnome-88ae9efc3a621d8a1021a9f7f712e376f7917a34.tar.gz
freebsd-ports-gnome-88ae9efc3a621d8a1021a9f7f712e376f7917a34.tar.zst
freebsd-ports-gnome-88ae9efc3a621d8a1021a9f7f712e376f7917a34.zip
- Use new options framework "SINGLE" feature.
- Pet portlint. PR: ports/168521 Submitted by: Baptiste Daroussin <bapt@FreeBSD.org> Approved by: crees, tabthorpe (mentors, implicit)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/amide/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/graphics/amide/Makefile b/graphics/amide/Makefile
index ad3b71900e4b..fc9aaf202952 100644
--- a/graphics/amide/Makefile
+++ b/graphics/amide/Makefile
@@ -28,12 +28,15 @@ INSTALLS_OMF= yes
MAN1= amide.1
-OPTIONS_DEFINE= DCMTK FAME FFMPEG GSL VOLPACK XMEDCON
-OPTIONS_DEFAULT= DCMTK FFMPEG GSL VOLPACK XMEDCON
+OPTIONS_DEFINE= CODEC DCMTK GSL VOLPACK XMEDCON
+OPTIONS_SINGLE= CODEC
+OPTIONS_SINGLE_CODEC= FFMPEG FAME
+OPTIONS_DEFAULT= CODEC DCMTK FFMPEG GSL VOLPACK XMEDCON
+CODEC_DESC= Enable codec support. Choose one of FAME or FFMPEG
DCMTK_DESC= Use dcmtk
-FAME_DESC= Use libfame (mutually exclusive with ffmpeg)
-FFMPEG_DESC= Use ffmpeg (mutually exclusive with libfame)
+FAME_DESC= Use libfame
+FFMPEG_DESC= Use ffmpeg
GSL_DESC= Use gsl
VOLPACK_DESC= Use volpack
XMEDCON_DESC= Use xmedcon
@@ -48,9 +51,6 @@ CONFIGURE_ARGS+= --disable-libdcmdata
.endif
.if ${PORT_OPTIONS:MFAME}
-. if${PORT_OPTIONS:MFFMPEG}
-IGNORE= libfame and ffmpeg support are mutually exclusive, please check options
-. endif
LIB_DEPENDS+= fame:${PORTSDIR}/multimedia/libfame
CONFIGURE_ARGS+= --enable-libfame
.else
@@ -58,9 +58,6 @@ CONFIGURE_ARGS+= --disable-libfame
.endif
.if ${PORT_OPTIONS:MFFMPEG}
-. if${PORT_OPTIONS:MFAME}
-IGNORE= libfame and ffmpeg support are mutually exclusive, please check options.
-. endif
LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-ffmpeg
.else