aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-07-26 07:48:35 +0800
committerjbeich <jbeich@FreeBSD.org>2016-07-26 07:48:35 +0800
commit8d30814f422be3b2fbfcd9b3b6e69ff8b15bb237 (patch)
tree9d6b20a998d372101c3d94f518af2a29704a7757 /graphics
parent4420ee78841f72a46219e2740c96564f80d012ca (diff)
downloadfreebsd-ports-gnome-8d30814f422be3b2fbfcd9b3b6e69ff8b15bb237.tar.gz
freebsd-ports-gnome-8d30814f422be3b2fbfcd9b3b6e69ff8b15bb237.tar.zst
freebsd-ports-gnome-8d30814f422be3b2fbfcd9b3b6e69ff8b15bb237.zip
graphics/cairo: clean up
- Convert to option helpers - Fix LICENSE combination - Add missing X11 dependencies [1] PR: 198996 [1] Submitted by: yuri@rawbw.com [1] Approved by: portmgr blanket MFH: 2016Q3
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cairo/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 300cf1dda8e4..6db09d935cf5 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cairo
PORTVERSION= 1.14.6
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
@@ -11,7 +12,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Vector graphics library with cross-device output support
LICENSE= LGPL21 MPL
-LICENSE_COMB= multi
+LICENSE_COMB= dual
USES= tar:xz
@@ -43,35 +44,28 @@ CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
OPTIONS_DEFINE= OPENGL XCB GLIB X11
OPTIONS_DEFAULT=OPENGL XCB GLIB X11
+OPTIONS_SLAVE= ${ARCH:tu}
XCB_DESC= Enable XCB (X C-language Binding) Support
GLIB_DESC= Enable GObject Functions Feature
OPTIONS_SUB= yes
-X11_USE= xorg=xrender,xext
+X11_USE= xorg=x11,xext,xrender
X11_CONFIGURE_ENABLE=xlib
OPENGL_USE= gl=gl,egl xorg=glproto:both,dri2proto:both
OPENGL_CONFIGURE_ENABLE=gl egl
+OPENGL_IMPLIES= X11
GLIB_USE= gnome=glib20
GLIB_CONFIGURE_ENABLE= gobject
XCB_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:x11/xcb-util-renderutil
XCB_RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xcb-renderutil.pc:x11/xcb-util-renderutil
+XCB_USE= xorg=xcb
XCB_CONFIGURE_ENABLE= xcb
# this has another option --enable-xlib-xcb=auto but it is buggy.
+MIPS_BUILD_DEPENDS= ${LOCALBASE}/include/atomic_ops.h:devel/libatomic_ops
+MIPS_USES= localbase
+MIPS_CONFIGURE_ENV= cairo_cv_atomic_primitives="libatomic-ops"
PLIST_SUB+= LIBVER=2.11400.6
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == "mips"
-BUILD_DEPENDS+= ${LOCALBASE}/include/atomic_ops.h:devel/libatomic_ops
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= cairo_cv_atomic_primitives="libatomic-ops"
-.endif
-
-.if ${PORT_OPTIONS:MOPENGL} && !${PORT_OPTIONS:MX11}
-BROKEN= OpenGL option needs X11 support
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/strings/s/ - / -a /' \
-e '/test/s/==/=/g' \