aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2005-06-13 04:15:01 +0800
committerlioux <lioux@FreeBSD.org>2005-06-13 04:15:01 +0800
commit914badb4b8a0de1bebc2044ba5aac29b798373db (patch)
treeedd3f1f6c4e52be12c855c5d7d517e30cf26fca9 /graphics
parent1531893f2a737677e0a18b47871e80660298f224 (diff)
downloadfreebsd-ports-gnome-914badb4b8a0de1bebc2044ba5aac29b798373db.tar.gz
freebsd-ports-gnome-914badb4b8a0de1bebc2044ba5aac29b798373db.tar.zst
freebsd-ports-gnome-914badb4b8a0de1bebc2044ba5aac29b798373db.zip
New port version 0.26.0: Convert/extract imanges in Microsoft
Windows(R) icon/cursor files
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/icoutils/Makefile33
-rw-r--r--graphics/icoutils/distinfo2
-rw-r--r--graphics/icoutils/pkg-descr16
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 7a3434d3aa2d..868e655d3e94 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -203,6 +203,7 @@
SUBDIR += icod
SUBDIR += icon-slicer
SUBDIR += icontact
+ SUBDIR += icoutils
SUBDIR += ida
SUBDIR += imageindex
SUBDIR += imagesort
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
new file mode 100644
index 000000000000..0615a91884e0
--- /dev/null
+++ b/graphics/icoutils/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: icoutils
+# Date created: Sun Jun 12 10:19:46 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icoutils
+PORTVERSION= 0.26.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Convert/extract imanges in Microsoft Windows(R) icon/cursor files
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ LIBS="-lintl"
+
+MAN1= extresso.1 genresscript.1 icotool.1 wrestool.1
+
+PLIST_FILES= \
+ bin/extresso \
+ bin/genresscript \
+ bin/icotool \
+ bin/wrestool
+
+.include <bsd.port.mk>
diff --git a/graphics/icoutils/distinfo b/graphics/icoutils/distinfo
new file mode 100644
index 000000000000..bee3e2d3ace0
--- /dev/null
+++ b/graphics/icoutils/distinfo
@@ -0,0 +1,2 @@
+MD5 (icoutils-0.26.0.tar.gz) = 5494ee42a9dad562b49c6b8721f973e8
+SIZE (icoutils-0.26.0.tar.gz) = 603257
diff --git a/graphics/icoutils/pkg-descr b/graphics/icoutils/pkg-descr
new file mode 100644
index 000000000000..019b61cfb32d
--- /dev/null
+++ b/graphics/icoutils/pkg-descr
@@ -0,0 +1,16 @@
+[ excerpt with modifications from developer's site ]
+
+The icoutils are a set of program for extracting and converting
+images in Microsoft Windows(R) icon and cursor files. These files
+usually have the extension .ico or .cur, but they can also be
+embedded in executables and libraries (.dll-files).
+
+The icotool program converts icon and cursor files into a set of
+PNG images. (Each icon/cursor file may contain multiple images,
+usually of different sizes and with different number of colors.)
+Icotool can also create icon/cursor files from PNG images.
+
+Author: Oskar Liljeblad <oskar@osk.mine.nu>
+WWW: http://www.nongnu.org/icoutils/
+
+-- lioux@FreeBSD.org