aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-09-19 18:12:50 +0800
committergahr <gahr@FreeBSD.org>2013-09-19 18:12:50 +0800
commit9f87dd7d4bcce343f6c5f2063484dbef25cc24c2 (patch)
tree5228f79356898dc7dfc51682704e1fc587d34613 /graphics
parentb7c7e24b5aaa99b9f9232523c1dae8195b76ad9d (diff)
downloadfreebsd-ports-gnome-9f87dd7d4bcce343f6c5f2063484dbef25cc24c2.tar.gz
freebsd-ports-gnome-9f87dd7d4bcce343f6c5f2063484dbef25cc24c2.tar.zst
freebsd-ports-gnome-9f87dd7d4bcce343f6c5f2063484dbef25cc24c2.zip
- Fix build when CC != gcc
- While at it, modernize the Makefile
Diffstat (limited to 'graphics')
-rw-r--r--graphics/separate/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/graphics/separate/Makefile b/graphics/separate/Makefile
index f29f5da8ab1a..eb8147d9e6b3 100644
--- a/graphics/separate/Makefile
+++ b/graphics/separate/Makefile
@@ -14,8 +14,8 @@ MAINTAINER= gahr@FreeBSD.org
COMMENT= A CMYK plugin for The GIMP
BUILD_DEPENDS= gccmakedep:${PORTSDIR}/devel/gccmakedep
-LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
- gimp-2.0:${PORTSDIR}/graphics/gimp-app
+LIB_DEPENDS= liblcms.so.1:${PORTSDIR}/graphics/lcms \
+ libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
USE_ZIP= yes
USES= gmake pkgconfig
@@ -35,12 +35,14 @@ PORTEXAMPLES= qproof.scm qexport.scm
MAKE_ENV+= TARGETS="${BIN_TARGETS}"
+.include <bsd.port.options.mk>
+
post-patch:
- @${REINPLACE_CMD} -e 's| make| ${GMAKE}|; s|lib/gimp/2.0|libexec/gimp/2.2|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|$$(PREFIX)|${PREFIX}|g' ${WRKSRC}/Makefile ${WRKSRC}/po/Makefile
+ @${REINPLACE_CMD} -e '/^CC/s|=|?=|; /^PREFIX/s|=|?=|; s| make| ${GMAKE}|; \
+ s|lib/gimp/2.0|libexec/gimp/2.2|' ${WRKSRC}/Makefile ${WRKSRC}/po/Makefile
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif