aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-12-22 16:18:50 +0800
committermat <mat@FreeBSD.org>2016-12-22 16:18:50 +0800
commita570d04bcb8cce16170b3f6309d3310b94d37f6a (patch)
tree50ebb577ca9ae3655f2712405ff2a8cfd7eee198 /graphics
parent80d6f0117bb48306458d84e36b031d38cdc8dfa4 (diff)
downloadfreebsd-ports-gnome-a570d04bcb8cce16170b3f6309d3310b94d37f6a.tar.gz
freebsd-ports-gnome-a570d04bcb8cce16170b3f6309d3310b94d37f6a.tar.zst
freebsd-ports-gnome-a570d04bcb8cce16170b3f6309d3310b94d37f6a.zip
Fix packaging.
Reported by: antoine Pointy hat: mat (for changing things after testing) Sponsored by: Absolight
Diffstat (limited to 'graphics')
-rw-r--r--graphics/code-eli/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/code-eli/Makefile b/graphics/code-eli/Makefile
index 866acf578c24..9cd719094a23 100644
--- a/graphics/code-eli/Makefile
+++ b/graphics/code-eli/Makefile
@@ -20,7 +20,6 @@ GH_ACCOUNT= ddmarshall
USES= cmake:outsource compiler:c++11-lib
PORTEXAMPLES= AirfoilFitExample VSPPodExample test
-PORTDOCS= html latex
ALL_TARGET= all
# Some useful variables
@@ -32,6 +31,7 @@ OPTIONS_DEFINE= DOXYGEN EXAMPLES
EXAMPLES_LIB_DEPENDS= libcpptest.so:devel/cpptest
DOXYGEN_BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:devel/doxygen
DOXYGEN_ALL_TARGET= doc
+DOXYGEN_PORTDOCS= html latex
# The code uses std::cbrt(). Even if one passes some additional macros for
# libstdc++ to enable additional math functions in math.h some of them, such as
@@ -45,16 +45,15 @@ post-patch-EXAMPLES-off:
${WRKSRC}/CMakeLists.txt
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/include/eli \
- ${STAGEDIR}${EXAMPLESDIR}${TEST_SUBDIR} \
- ${STAGEDIR}${EXAMPLESDIR} \
- ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/eli
${INSTALL_DATA} ${BUILD_WRKSRC}/include/eli/code_eli.hpp \
${STAGEDIR}${PREFIX}/include/eli
(cd ${WRKSRC}/include/eli && \
${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include/eli "*")
do-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}${TEST_SUBDIR} \
+ ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} \
${BUILD_WRKSRC}/example/${VSPPOD_DIR}/VSPPodExample \
${BUILD_WRKSRC}/example/${AIRFOIL_DIR}/AirfoilFitExample \
@@ -70,6 +69,7 @@ do-install-EXAMPLES-on:
${XARGS} ${STRIP_CMD}
do-install-DOXYGEN-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${BUILD_WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>