aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-17 06:53:56 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-17 06:53:56 +0800
commita89a93706ce9bb9ebc540df88ae6121c7208d074 (patch)
tree29895f70d76cff04da5f31fcd4ac4d43c795373e /graphics
parentc2392fa5e62113dd08b039a415f9aa0268fd2e6a (diff)
downloadfreebsd-ports-gnome-a89a93706ce9bb9ebc540df88ae6121c7208d074.tar.gz
freebsd-ports-gnome-a89a93706ce9bb9ebc540df88ae6121c7208d074.tar.zst
freebsd-ports-gnome-a89a93706ce9bb9ebc540df88ae6121c7208d074.zip
Add xmms-dscope.
Dual Scope is a visualization plugin for XMMS. WWW: http://www.shell.linux.se/bm/index.php?page=xmmsplugin PR: ports/82302 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xmms-dscope/Makefile32
-rw-r--r--graphics/xmms-dscope/distinfo2
-rw-r--r--graphics/xmms-dscope/files/patch-dscope.c10
-rw-r--r--graphics/xmms-dscope/pkg-descr6
-rw-r--r--graphics/xmms-dscope/pkg-plist4
6 files changed, 55 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e36863a6f3cf..4c683ef4f34c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -570,6 +570,7 @@
SUBDIR += xmedcon
SUBDIR += xmfract
SUBDIR += xmms-blursk
+ SUBDIR += xmms-dscope
SUBDIR += xmms-dspectogram
SUBDIR += xmms-dspectral
SUBDIR += xmms-finespectrum
diff --git a/graphics/xmms-dscope/Makefile b/graphics/xmms-dscope/Makefile
new file mode 100644
index 000000000000..0c9442417e36
--- /dev/null
+++ b/graphics/xmms-dscope/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: graphics/xmms-dscope
+# Date created: 15 Jun 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dscope
+PORTVERSION= 1.3.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.shell.linux.se/bm/f/
+PKGNAMEPREFIX= xmms-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^/v/}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Dual Scope visualization plugin for XMMS
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GNOME= gtk12
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-O3||; \
+ s|-Wall|-Wall ${CFLAGS}|; \
+ s|gtk-config|${GTK_CONFIG}|; \
+ s|install lib|${INSTALL_PROGRAM} lib|; \
+ s|install bg|${INSTALL_DATA} bg|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/graphics/xmms-dscope/distinfo b/graphics/xmms-dscope/distinfo
new file mode 100644
index 000000000000..63c862fbcb88
--- /dev/null
+++ b/graphics/xmms-dscope/distinfo
@@ -0,0 +1,2 @@
+MD5 (dscope-v1.3.1.tar.gz) = a883144570402cd67eb1090a4b9b529a
+SIZE (dscope-v1.3.1.tar.gz) = 35920
diff --git a/graphics/xmms-dscope/files/patch-dscope.c b/graphics/xmms-dscope/files/patch-dscope.c
new file mode 100644
index 000000000000..5a536509703c
--- /dev/null
+++ b/graphics/xmms-dscope/files/patch-dscope.c
@@ -0,0 +1,10 @@
+--- dscope.c.orig Sun Nov 10 16:01:05 2002
++++ dscope.c Wed Jun 15 18:51:15 2005
+@@ -11,6 +11,7 @@
+ #include <math.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <xmms/plugin.h>
+ #include <xmms/configfile.h>
+
diff --git a/graphics/xmms-dscope/pkg-descr b/graphics/xmms-dscope/pkg-descr
new file mode 100644
index 000000000000..2ad2a6b35955
--- /dev/null
+++ b/graphics/xmms-dscope/pkg-descr
@@ -0,0 +1,6 @@
+Dual Scope is a visualization plugin for XMMS.
+
+WWW: http://www.shell.linux.se/bm/index.php?page=xmmsplugin
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/graphics/xmms-dscope/pkg-plist b/graphics/xmms-dscope/pkg-plist
new file mode 100644
index 000000000000..75ac7a59a20a
--- /dev/null
+++ b/graphics/xmms-dscope/pkg-plist
@@ -0,0 +1,4 @@
+lib/xmms/Visualization/libdscope.so
+share/xmms/dscope_themes/bg_gtk.xpm
+share/xmms/dscope_themes/bg_xmms.xpm
+@dirrm share/xmms/dscope_themes