aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2018-02-21 18:07:43 +0800
committerehaupt <ehaupt@FreeBSD.org>2018-02-21 18:07:43 +0800
commitb12fee965221a1a91af198dbe35f2b24b54d4be5 (patch)
tree3c5089fb0105b381321dea2855ed09204e20a287 /graphics
parent590e5bd146962cdd4cc35dd9612f3fa86a4a6b3a (diff)
downloadfreebsd-ports-gnome-b12fee965221a1a91af198dbe35f2b24b54d4be5.tar.gz
freebsd-ports-gnome-b12fee965221a1a91af198dbe35f2b24b54d4be5.tar.zst
freebsd-ports-gnome-b12fee965221a1a91af198dbe35f2b24b54d4be5.zip
Fix build on 12.0-CURRENT after upgrading clang, llvm, lld, lldb, compiler-rt
and libc++ to 6.0.0 by falling back to gcc. Notified by: pkg-fallout
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fig2sxd/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/fig2sxd/Makefile b/graphics/fig2sxd/Makefile
index 400df6b468ae..cf16d9778314 100644
--- a/graphics/fig2sxd/Makefile
+++ b/graphics/fig2sxd/Makefile
@@ -16,6 +16,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/fig2sxd man/man1/fig2sxd.1.gz
+.include <bsd.port.pre.mk>
+
+# does not compile with clang 6.0.0
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200056
+USE_GCC= yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
'/^CXX/d; s|^\(all:\).*|\1 $$(TARGET1) fig2sxd.1|' \
@@ -25,4 +32,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>