aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
committertijl <tijl@FreeBSD.org>2014-09-25 23:18:27 +0800
commitb20f32bb38994e1bb5de05cecc229f10659e0f49 (patch)
treec350c4abc20ce22bda0b7dba0636816742669bc8 /graphics
parent20be128769eb36776631a3639656f9528820a14c (diff)
downloadfreebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.gz
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.tar.zst
freebsd-ports-gnome-b20f32bb38994e1bb5de05cecc229f10659e0f49.zip
- Set CPPFLAGS and LIBS in a number of ports so configure can find libintl.h
and libintl.so. This fixes a problem where DATADIRNAME gets an incorrect value which causes locale files to be installed in the wrong place. - The only configure checks that still need to be patched are related to intltool so move DATADIRNAME patching from USES=pathfix to USE_GNOME=intlhack. - games/klavaro: remove excessive dependencies - japanese/libskk: add INSTALL_TARGET=install-strip - math/libqalculate: add INSTALL_TARGET=install-strip and remove pthread patching - multimedia/freetuxtv: remove excessive dependencies - science/gramps: fix shared-mime-info use Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gimp-save-for-web/Makefile9
-rw-r--r--graphics/ocrfeeder/Makefile4
2 files changed, 7 insertions, 6 deletions
diff --git a/graphics/gimp-save-for-web/Makefile b/graphics/gimp-save-for-web/Makefile
index a945e42d3eef..b9aad25c362e 100644
--- a/graphics/gimp-save-for-web/Makefile
+++ b/graphics/gimp-save-for-web/Makefile
@@ -13,12 +13,11 @@ COMMENT= GIMP Save For Web plugin
LIB_DEPENDS= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-USES= gettext gmake pkgconfig pathfix perl5 tar:bzip2
-USE_PERL5= build
GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+USES= gettext gmake perl5 pkgconfig tar:bzip2
+USE_PERL5= build
USE_GNOME= intltool
-post-patch:
- @${REINPLACE_CMD} -e 's|GMSGFMT = @GMSGFMT@|GMSGFMT = @MSGFMT@|g' ${WRKSRC}/po/Makefile.in.in
-
.include <bsd.port.mk>
diff --git a/graphics/ocrfeeder/Makefile b/graphics/ocrfeeder/Makefile
index 71609c471434..f804183256be 100644
--- a/graphics/ocrfeeder/Makefile
+++ b/graphics/ocrfeeder/Makefile
@@ -23,12 +23,14 @@ RUN_DEPENDS:= ${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
gtkspell3>0:${PORTSDIR}/textproc/gtkspell3 \
${BUILD_DEPENDS}
-USES= desktop-file-utils gettext gmake pathfix pkgconfig tar:xz
+USES= desktop-file-utils gettext gmake pkgconfig tar:xz
USE_GNOME= gnomedocutils gnomehier gtk30 librsvg2 pygobject3
USE_GHOSTSCRIPT=yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-silent-rules
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e \