aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2015-06-25 16:36:42 +0800
committeravilla <avilla@FreeBSD.org>2015-06-25 16:36:42 +0800
commitb432d6a675f0e79611c6e140229aa6697aff65b8 (patch)
tree865778f50c7ad4174e54ad31498d68e8c50d3797 /graphics
parent86b244de0425a94f53e13cd7ef1ea1364bf669ad (diff)
downloadfreebsd-ports-gnome-b432d6a675f0e79611c6e140229aa6697aff65b8.tar.gz
freebsd-ports-gnome-b432d6a675f0e79611c6e140229aa6697aff65b8.tar.zst
freebsd-ports-gnome-b432d6a675f0e79611c6e140229aa6697aff65b8.zip
graphics/opencv: fix configure when EIGEN is off
When EIGEN option is off, CMAKE_ARGS is reset, thus enabling build of tests and docs (causing some leftovers), and, should it be installed, linking against libdc1394 even when option DC1394 is off. PORTREVISION bump is needed to address the latter case. Meanwhile, re-enable make jobs. Differential Revision: https://reviews.freebsd.org/D2893 Reviewed by: jhale (maintainer) Approved by: jhale (maintainer) MFH: 2015Q2
Diffstat (limited to 'graphics')
-rw-r--r--graphics/opencv/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index ed691a08fe28..f12498fd389d 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= opencv
PORTVERSION= 2.4.9
-PORTREVISION?= 5
+PORTREVISION?= 6
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}library/${PORTNAME}-unix/${PORTVERSION}
@@ -16,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake pkgconfig zip
USE_LDCONFIG= yes
WANT_GSTREAMER= yes
-MAKE_JOBS_UNSAFE= yes
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON_sparc64= does not compile on sparc64
@@ -76,7 +75,7 @@ CMAKE_ARGS+= -DWITH_1394:BOOL=Off
BUILD_DEPENDS+= ${LOCALBASE}/include/eigen3/Eigen/Eigen:${PORTSDIR}/math/eigen3
CMAKE_ARGS+= -DWITH_EIGEN:BOOL=On
.else
-CMAKE_ARGS= -DWITH_EIGEN:BOOL=Off
+CMAKE_ARGS+= -DWITH_EIGEN:BOOL=Off
.endif
.if ${PORT_OPTIONS:MEXAMPLES}