aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-17 00:38:40 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-17 00:38:40 +0800
commitb8996fe59a70dc0054db56bdafd6b2da406c19c6 (patch)
tree6b4abc14b068ab900ced4696877ebe13c2c2f11d /graphics
parenta45008e07005881a19d3ea3ba3753e3749b2b594 (diff)
downloadfreebsd-ports-gnome-b8996fe59a70dc0054db56bdafd6b2da406c19c6.tar.gz
freebsd-ports-gnome-b8996fe59a70dc0054db56bdafd6b2da406c19c6.tar.zst
freebsd-ports-gnome-b8996fe59a70dc0054db56bdafd6b2da406c19c6.zip
Add xmms-dspectral.
Dual Spectralizer is a visualization plugin for XMMS. WWW: http://www.shell.linux.se/bm/index.php?page=xmmsplugin PR: ports/82300 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xmms-dspectral/Makefile32
-rw-r--r--graphics/xmms-dspectral/distinfo2
-rw-r--r--graphics/xmms-dspectral/files/patch-dspectral.c10
-rw-r--r--graphics/xmms-dspectral/pkg-descr6
-rw-r--r--graphics/xmms-dspectral/pkg-plist7
6 files changed, 58 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 745cc3cfa861..689169fb801e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -570,6 +570,7 @@
SUBDIR += xmedcon
SUBDIR += xmfract
SUBDIR += xmms-blursk
+ SUBDIR += xmms-dspectral
SUBDIR += xmms-finespectrum
SUBDIR += xmms-fishmatic
SUBDIR += xmms-gdancer
diff --git a/graphics/xmms-dspectral/Makefile b/graphics/xmms-dspectral/Makefile
new file mode 100644
index 000000000000..c9ea08f71809
--- /dev/null
+++ b/graphics/xmms-dspectral/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: graphics/xmms-dspectral
+# Date created: 15 Jun 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dspectral
+PORTVERSION= 1.2.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.shell.linux.se/bm/f/
+PKGNAMEPREFIX= xmms-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^/v/}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Dual Spectralizer visualization plugin for XMMS
+
+BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GNOME= gtk12
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-m486||; s|-O2||; \
+ s|-Wall|-Wall ${CFLAGS}|; \
+ s|gtk-config|${GTK_CONFIG}|; \
+ s|install lib|${INSTALL_PROGRAM} lib|; \
+ s|install bg|${INSTALL_DATA} bg|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/graphics/xmms-dspectral/distinfo b/graphics/xmms-dspectral/distinfo
new file mode 100644
index 000000000000..ebd482640074
--- /dev/null
+++ b/graphics/xmms-dspectral/distinfo
@@ -0,0 +1,2 @@
+MD5 (dspectral-v1.2.1.tar.gz) = 8500a7ad53841d90dfec852c080b7fd7
+SIZE (dspectral-v1.2.1.tar.gz) = 43983
diff --git a/graphics/xmms-dspectral/files/patch-dspectral.c b/graphics/xmms-dspectral/files/patch-dspectral.c
new file mode 100644
index 000000000000..8186085d43e0
--- /dev/null
+++ b/graphics/xmms-dspectral/files/patch-dspectral.c
@@ -0,0 +1,10 @@
+--- dspectral.c.orig Sun Nov 10 16:01:07 2002
++++ dspectral.c Wed Jun 15 19:17:02 2005
+@@ -12,6 +12,7 @@
+ #include <math.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <xmms/plugin.h>
+ #include <xmms/configfile.h>
+
diff --git a/graphics/xmms-dspectral/pkg-descr b/graphics/xmms-dspectral/pkg-descr
new file mode 100644
index 000000000000..aacc779680a1
--- /dev/null
+++ b/graphics/xmms-dspectral/pkg-descr
@@ -0,0 +1,6 @@
+Dual Spectralizer is a visualization plugin for XMMS.
+
+WWW: http://www.shell.linux.se/bm/index.php?page=xmmsplugin
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/graphics/xmms-dspectral/pkg-plist b/graphics/xmms-dspectral/pkg-plist
new file mode 100644
index 000000000000..7a4193c1559a
--- /dev/null
+++ b/graphics/xmms-dspectral/pkg-plist
@@ -0,0 +1,7 @@
+lib/xmms/Visualization/libdspectral.so
+share/xmms/dspectral_themes/bg_blue.xpm
+share/xmms/dspectral_themes/bg_darkgreen.xpm
+share/xmms/dspectral_themes/bg_gtk.xpm
+share/xmms/dspectral_themes/bg_white.xpm
+share/xmms/dspectral_themes/bg_xmms.xpm
+@dirrm share/xmms/dspectral_themes