aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjoe <joe@FreeBSD.org>2002-03-08 04:34:40 +0800
committerjoe <joe@FreeBSD.org>2002-03-08 04:34:40 +0800
commitbbda2b427b861073aca64a1f1bfb6b774db15217 (patch)
treee92f120b91415261f88804a9ec0b3acba86f4229 /graphics
parent3074f0a98b6038b0a34454d6ccfad4513f7b3b81 (diff)
downloadfreebsd-ports-gnome-bbda2b427b861073aca64a1f1bfb6b774db15217.tar.gz
freebsd-ports-gnome-bbda2b427b861073aca64a1f1bfb6b774db15217.tar.zst
freebsd-ports-gnome-bbda2b427b861073aca64a1f1bfb6b774db15217.zip
Fix a header problem bug.
Install the correct header files for applications to use. Submitted by: David Hanney <dh@digitalbrain.com>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ming/files/Makefile4
-rw-r--r--graphics/ming/files/patch-mingpp.h11
2 files changed, 13 insertions, 2 deletions
diff --git a/graphics/ming/files/Makefile b/graphics/ming/files/Makefile
index ad7640a226dc..0f1057fb25c3 100644
--- a/graphics/ming/files/Makefile
+++ b/graphics/ming/files/Makefile
@@ -57,8 +57,8 @@ INCS= blocklist.h \
displaylist.h \
fill.h \
libming.h \
- ming.h \
- mingpp.h \
+ ../ming.h \
+ ../mingpp.h \
movie.h \
movieclip.h \
position.h \
diff --git a/graphics/ming/files/patch-mingpp.h b/graphics/ming/files/patch-mingpp.h
new file mode 100644
index 000000000000..8fd367014b28
--- /dev/null
+++ b/graphics/ming/files/patch-mingpp.h
@@ -0,0 +1,11 @@
+--- ../mingpp.h Thu Mar 7 18:28:27 2002
++++ ../mingpp.h Thu Mar 7 18:28:41 2002
+@@ -627,7 +627,7 @@
+ void setColor(unsigned char r, unsigned char g, unsigned char b, int a=0xff)
+ { SWFText_setColor(this->text, r, g, b, a); }
+
+- void addString(const char *string, float *advance=NULL)
++ void addString(const char *string, int *advance=NULL)
+ { SWFText_addString(this->text, string, advance); }
+
+ void setSpacing(float spacing)