aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2018-01-18 04:38:40 +0800
committerjkim <jkim@FreeBSD.org>2018-01-18 04:38:40 +0800
commitbc9cc0dcdd010cd59026da938737eb9955a892e5 (patch)
tree980e937713e4249fda2411bcd6630f3d5207f515 /graphics
parent5d5a18ed19124f22ebf8cd5bafc3455d7ef4cd64 (diff)
downloadfreebsd-ports-gnome-bc9cc0dcdd010cd59026da938737eb9955a892e5.tar.gz
freebsd-ports-gnome-bc9cc0dcdd010cd59026da938737eb9955a892e5.tar.zst
freebsd-ports-gnome-bc9cc0dcdd010cd59026da938737eb9955a892e5.zip
- Fix build with Clang 6.0. [1]
- Fix license and prefer HTTPS for WWW. PR: 225006 [1]
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libgltf/Makefile6
-rw-r--r--graphics/libgltf/files/patch-src_Shaders.cpp11
-rw-r--r--graphics/libgltf/pkg-descr2
3 files changed, 15 insertions, 4 deletions
diff --git a/graphics/libgltf/Makefile b/graphics/libgltf/Makefile
index f4a0c3dd677a..bd7dd039a015 100644
--- a/graphics/libgltf/Makefile
+++ b/graphics/libgltf/Makefile
@@ -2,15 +2,15 @@
PORTNAME= libgltf
PORTVERSION= 0.0.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= graphics devel
MASTER_SITES= LODEV
MAINTAINER= office@FreeBSD.org
COMMENT= C++ Library for rendering OpenGL models stored in glTF format
-LICENSE= LGPL21 MPL20
-LICENSE_COMB= dual
+LICENSE= MPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/boost/ptr_container/ptr_map.hpp:devel/boost-libs \
${LOCALBASE}/include/glm/glm.hpp:math/glm
diff --git a/graphics/libgltf/files/patch-src_Shaders.cpp b/graphics/libgltf/files/patch-src_Shaders.cpp
new file mode 100644
index 000000000000..a5a68b445ed9
--- /dev/null
+++ b/graphics/libgltf/files/patch-src_Shaders.cpp
@@ -0,0 +1,11 @@
+--- src/Shaders.cpp.orig 2014-10-01 18:31:43 UTC
++++ src/Shaders.cpp
+@@ -175,7 +175,7 @@ bool ShaderProgram::compileShader(const char* pShader,
+ };
+
+ const GLint aSizes[] = {
+- strlen("#version 130\n"),
++ sizeof("#version 130\n") - 1,
+ iGLSize,
+ };
+
diff --git a/graphics/libgltf/pkg-descr b/graphics/libgltf/pkg-descr
index e4fe49131bad..fe60882a49fb 100644
--- a/graphics/libgltf/pkg-descr
+++ b/graphics/libgltf/pkg-descr
@@ -1,3 +1,3 @@
Library for rendering OpenGL models stored in glTF format
-WWW: http://www.libreoffice.org
+WWW: https://www.libreoffice.org