aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-02-08 13:27:23 +0800
committernork <nork@FreeBSD.org>2003-02-08 13:27:23 +0800
commitbcaf0cc859979f817b619fb3c392cc9f40013e3e (patch)
treec6d8d26a5795ae9004c15caa3ad95ff6529be0ca /graphics
parent1fd574cb9715ad397dc0e1a967f6d67b2eb25333 (diff)
downloadfreebsd-ports-gnome-bcaf0cc859979f817b619fb3c392cc9f40013e3e.tar.gz
freebsd-ports-gnome-bcaf0cc859979f817b619fb3c392cc9f40013e3e.tar.zst
freebsd-ports-gnome-bcaf0cc859979f817b619fb3c392cc9f40013e3e.zip
Change CPPFLAGS+=/LDFLAGS+= to CPPFLAGS=/LDFLAGS=.
Submitted by: Ports Fury
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gliv/Makefile4
-rw-r--r--graphics/gts/Makefile4
-rw-r--r--graphics/libwpcg/Makefile4
-rw-r--r--graphics/pstoedit/Makefile4
-rw-r--r--graphics/qslim/Makefile4
5 files changed, 10 insertions, 10 deletions
diff --git a/graphics/gliv/Makefile b/graphics/gliv/Makefile
index f9d961829321..9f2d86706a87 100644
--- a/graphics/gliv/Makefile
+++ b/graphics/gliv/Makefile
@@ -24,8 +24,8 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= gliv.1
-CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib -lXext -lX11 ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lXext -lX11 ${PTHREAD_LIBS}
.if !exists(/usr/include/getopt.h)
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index ec987463a319..7eb4cf18b684 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -22,8 +22,8 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.if !exists(/usr/include/getopt.h)
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
diff --git a/graphics/libwpcg/Makefile b/graphics/libwpcg/Makefile
index d63bf567388a..bc6f6ea86ce5 100644
--- a/graphics/libwpcg/Makefile
+++ b/graphics/libwpcg/Makefile
@@ -18,7 +18,7 @@ USE_GCC= 3.1
USE_MESA= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${X11BASE}/include" \
- LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -lGL -lGLU -lglut"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LDFLAGS="-L${X11BASE}/lib -lGL -lGLU -lglut"
.include <bsd.port.mk>
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index a133e6a3ee7c..26104ee0a4c7 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -27,9 +27,9 @@ INSTALLS_SHLIB= yes
MAN1= pstoedit.1
-CPPFLAGS+= -I${LOCALBASE}/include/ming -I${LOCALBASE}/include \
+CPPFLAGS= -I${LOCALBASE}/include/ming -I${LOCALBASE}/include \
-I${X11BASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/pstoedit.1 ${MANPREFIX}/man/man1
diff --git a/graphics/qslim/Makefile b/graphics/qslim/Makefile
index a223e81f8aeb..4148a364cce3 100644
--- a/graphics/qslim/Makefile
+++ b/graphics/qslim/Makefile
@@ -27,9 +27,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= # none
-CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include \
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
-I${X11BASE}/include/X11 ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>