aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-17 23:15:23 +0800
committeradamw <adamw@FreeBSD.org>2014-08-17 23:15:23 +0800
commitbf357789cf0fa842708ea63365d97af89ede9922 (patch)
tree4e36790a2b4e1999feb89e7e2fa32f42a964e59e /graphics
parentf20cc6fee932097263cd241e078dd03c476ef975 (diff)
downloadfreebsd-ports-gnome-bf357789cf0fa842708ea63365d97af89ede9922.tar.gz
freebsd-ports-gnome-bf357789cf0fa842708ea63365d97af89ede9922.tar.zst
freebsd-ports-gnome-bf357789cf0fa842708ea63365d97af89ede9922.zip
Teach 'coin-config --ldflags' to use -Wl,-rpath,/usr/local/lib instead
of -R/usr/local/lib. This is required on -current but should work fine elsewhere.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Coin/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index 37c788b55df0..c1538c3c37d5 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Coin
PORTVERSION= 3.1.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/Coin3D/coin/downloads/
@@ -29,4 +29,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|DATA install-data-local|DATA|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+post-build:
+ @${REINPLACE_CMD} -e '/^ldflags=/s|-R|-Wl,-rpath,|' ${WRKSRC}/coin-default.cfg
+
.include <bsd.port.mk>