aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-09 02:31:40 +0800
committerantoine <antoine@FreeBSD.org>2014-01-09 02:31:40 +0800
commitc38cc962d08fd9a5e0e60fbec4e29292f3253dd4 (patch)
tree7da9cccec8b83216feee2e305973193feea7f4f4 /graphics
parenta3388c5c900982c96940e2e4f2ceaef1e3d26a89 (diff)
downloadfreebsd-ports-gnome-c38cc962d08fd9a5e0e60fbec4e29292f3253dd4.tar.gz
freebsd-ports-gnome-c38cc962d08fd9a5e0e60fbec4e29292f3253dd4.tar.zst
freebsd-ports-gnome-c38cc962d08fd9a5e0e60fbec4e29292f3253dd4.zip
- Remove NO_INSTALL_MANPAGES, it's useless with custom do-install target
- Stage support - Fix build on head amd64 (MAKE_ENV was overriden) - Add missing OPTIONS_DEFINE PR: ports/185514 Submitted by: KATO Tsuguru
Diffstat (limited to 'graphics')
-rw-r--r--graphics/lfview/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/graphics/lfview/Makefile b/graphics/lfview/Makefile
index c47554361a3d..8598de5c17cd 100644
--- a/graphics/lfview/Makefile
+++ b/graphics/lfview/Makefile
@@ -14,23 +14,24 @@ COMMENT= Graphic viewer for Leaf products
USES= imake
USE_XORG= x11 xext
USE_LDCONFIG= yes
-NO_INSTALL_MANPAGES= yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS
+DOCSDIR= ${PREFIX}/share/doc/ja/lfview
-.if ${ARCH} == "amd64"
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != i386
CFLAGS+= -fPIC
-MAKE_ENV= "SHLIBGLOBALSFLAGS=-fPIC"
+MAKE_ENV+= SHLIBGLOBALSFLAGS=-fPIC
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lfview ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/plugins/liblfv_leaf.so.1 ${PREFIX}/lib
- ${LN} -s ${PREFIX}/lib/liblfv_leaf.so.1 ${PREFIX}/lib/liblfv_leaf.so
+ ${INSTALL_PROGRAM} ${WRKSRC}/lfview ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_LIB} ${WRKSRC}/plugins/liblfv_leaf.so.1 ${STAGEDIR}${PREFIX}/lib
+ ${LN} -sf liblfv_leaf.so.1 ${STAGEDIR}${PREFIX}/lib/liblfv_leaf.so
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${PREFIX}/share/doc/ja/lfview
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ja/lfview
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>