aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-09-19 23:19:59 +0800
committerpawel <pawel@FreeBSD.org>2012-09-19 23:19:59 +0800
commitcef962b1ead0dbedee2a87f987737ed7daf8fa85 (patch)
treec9db88f286fea3ac1a08db65dd0e3105110294ca /graphics
parent8e0c547e83f31d2890d05efc6ffaa58f566fb4dd (diff)
downloadfreebsd-ports-gnome-cef962b1ead0dbedee2a87f987737ed7daf8fa85.tar.gz
freebsd-ports-gnome-cef962b1ead0dbedee2a87f987737ed7daf8fa85.tar.zst
freebsd-ports-gnome-cef962b1ead0dbedee2a87f987737ed7daf8fa85.zip
OpenColorIO (OCIO) is a complete color management solution geared
towards motion picture production with an emphasis on visual effects and computer animation. WWW: http://www.opencolorio.org PR: ports/171667 Submitted by: FreeBSD@Shaneware.biz
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/opencolorio/Makefile78
-rw-r--r--graphics/opencolorio/distinfo2
-rw-r--r--graphics/opencolorio/files/patch-src_apps_ocioconvert_CMakeLists.txt11
-rw-r--r--graphics/opencolorio/files/patch-src_apps_ociolutimage_CMakeLists.txt11
-rw-r--r--graphics/opencolorio/files/patch-src_core_CMakeLists.txt8
-rw-r--r--graphics/opencolorio/files/patch-src_core_Platform.h12
-rw-r--r--graphics/opencolorio/pkg-descr5
-rw-r--r--graphics/opencolorio/pkg-plist18
9 files changed, 146 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 1c9390acfc9d..4178238af207 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -589,6 +589,7 @@
SUBDIR += ogre3d
SUBDIR += okular
SUBDIR += openclipart
+ SUBDIR += opencolorio
SUBDIR += opencsg
SUBDIR += opencv
SUBDIR += opencv-core
diff --git a/graphics/opencolorio/Makefile b/graphics/opencolorio/Makefile
new file mode 100644
index 000000000000..26fb915f84d2
--- /dev/null
+++ b/graphics/opencolorio/Makefile
@@ -0,0 +1,78 @@
+# Created by: Shane Ambler <FreeBSD@Shaneware.biz>
+# $FreeBSD$
+
+PORTNAME= opencolorio
+PORTVERSION= 1.0.7
+CATEGORIES= graphics multimedia
+MASTER_SITES= https://github.com/imageworks/OpenColorIO/tarball/
+DISTNAME= v${PORTVERSION}
+EXTRACT_SUFX= # empty
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= FreeBSD@Shaneware.biz
+COMMENT= Complete color management solution
+
+LICENSE= BSD
+
+LIB_DEPENDS= OpenImageIO:${PORTSDIR}/graphics/openimageio
+
+FETCH_ARGS= -pRr
+USE_CMAKE= yes
+CMAKE_VERBOSE= yes
+CMAKE_OUTSOURCE= yes
+CMAKE_ARGS= -DOCIO_BUILD_JNIGLUE:BOOL=OFF \
+ -DOCIO_BUILD_PYGLUE:BOOL=OFF
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/imageworks-OpenColorIO-b3cb224
+MAKE_JOBS_SAFE= yes
+
+OPTIONS_DEFINE= CLIAPPS SSE
+OPTIONS_DEFAULT= SSE
+
+CLIAPPS_DESC= Build cli apps
+SSE_DESC= Enable sse optimizations
+
+.include <bsd.port.options.mk>
+
+.if ${CC:T} != "clang"
+USE_GCC= 4.6+
+.endif
+
+.if empty(PORT_OPTIONS:MDOCS)
+CMAKE_ARGS+= -DOCIO_BUILD_DOCS:BOOL=OFF
+.else
+# docs currently broken
+CMAKE_ARGS+= -DOCIO_BUILD_DOCS:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MCLIAPPS}
+.if ${CC:T} != "clang"
+BROKEN= cli apps don't build with gcc
+.endif
+CMAKE_ARGS+= -DOCIO_BUILD_APPS:BOOL=ON
+PLIST_SUB+= CLIAPPS=""
+.else
+CMAKE_ARGS+= -DOCIO_BUILD_APPS:BOOL=OFF
+PLIST_SUB+= CLIAPPS="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386" || ${OSVERSION} < 803000
+# this is needed for linking with openimageio
+LDFLAGS+= -L${LOCALBASE}/lib/gcc46 -rpath ${LOCALBASE}/lib/gcc46
+.endif
+
+.if ${CC:T} == "clang" && ${ARCH} == "i386"
+# workaround for pr/165968
+# may need to test osversion after fix is applied
+CFLAGS+= -march=pentium2
+.endif
+
+.if ${PORT_OPTIONS:MSSE}
+CMAKE_ARGS+= -DOCIO_USE_SSE:BOOL=ON
+.else
+CMAKE_ARGS+= -DOCIO_USE_SSE:BOOL=OFF
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/opencolorio/distinfo b/graphics/opencolorio/distinfo
new file mode 100644
index 000000000000..9f491d31178b
--- /dev/null
+++ b/graphics/opencolorio/distinfo
@@ -0,0 +1,2 @@
+SHA256 (opencolorio/v1.0.7) = 54c6516a89dc9287f1bcc47f27a91fb608477295a4ba6106b45f34e89506d7d5
+SIZE (opencolorio/v1.0.7) = 11844185
diff --git a/graphics/opencolorio/files/patch-src_apps_ocioconvert_CMakeLists.txt b/graphics/opencolorio/files/patch-src_apps_ocioconvert_CMakeLists.txt
new file mode 100644
index 000000000000..0eda747c65f1
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_apps_ocioconvert_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/apps/ocioconvert/CMakeLists.txt.orig 2012-06-21 20:37:46.118893014 +0930
++++ src/apps/ocioconvert/CMakeLists.txt 2012-06-21 20:38:07.547827470 +0930
+@@ -10,7 +10,7 @@
+
+ add_executable(ocioconvert ${share_src_files} main.cpp)
+
+- target_link_libraries(ocioconvert ${OIIO_LIBRARIES} OpenColorIO dl)
++ target_link_libraries(ocioconvert ${OIIO_LIBRARIES} OpenColorIO)
+
+ install(TARGETS ocioconvert DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)
+ endif()
diff --git a/graphics/opencolorio/files/patch-src_apps_ociolutimage_CMakeLists.txt b/graphics/opencolorio/files/patch-src_apps_ociolutimage_CMakeLists.txt
new file mode 100644
index 000000000000..056c7da954d2
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_apps_ociolutimage_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- src/apps/ociolutimage/CMakeLists.txt.orig 2012-04-18 09:38:16.000000000 +0930
++++ src/apps/ociolutimage/CMakeLists.txt 2012-06-21 20:40:39.147826612 +0930
+@@ -10,7 +10,7 @@
+
+ add_executable(ociolutimage ${share_src_files} main.cpp)
+
+- target_link_libraries(ociolutimage ${OIIO_LIBRARIES} OpenColorIO dl)
++ target_link_libraries(ociolutimage ${OIIO_LIBRARIES} OpenColorIO)
+
+ install(TARGETS ociolutimage DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/bin)
+ endif()
diff --git a/graphics/opencolorio/files/patch-src_core_CMakeLists.txt b/graphics/opencolorio/files/patch-src_core_CMakeLists.txt
new file mode 100644
index 000000000000..019c31266307
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_core_CMakeLists.txt
@@ -0,0 +1,8 @@
+--- src/core/CMakeLists.txt.orig 2012-09-19 16:50:29.000000000 +0200
++++ src/core/CMakeLists.txt 2012-09-19 16:51:18.000000000 +0200
+@@ -90,4 +90,4 @@
+ configure_file(${CMAKE_SOURCE_DIR}/export/pkgconfig/OpenColorIO.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/OpenColorIO.pc @ONLY)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/OpenColorIO.pc
+- DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/lib${LIB_SUFFIX}/pkgconfig/)
++ DESTINATION ${CMAKE_INSTALL_EXEC_PREFIX}/libdata/pkgconfig/)
diff --git a/graphics/opencolorio/files/patch-src_core_Platform.h b/graphics/opencolorio/files/patch-src_core_Platform.h
new file mode 100644
index 000000000000..137c3547fae2
--- /dev/null
+++ b/graphics/opencolorio/files/patch-src_core_Platform.h
@@ -0,0 +1,12 @@
+--- src/core/Platform.h.orig 2012-06-21 20:18:57.343827187 +0930
++++ src/core/Platform.h 2012-06-21 20:20:38.915828064 +0930
+@@ -85,7 +85,9 @@
+
+ // linux/unix/posix
+ #include <stdlib.h>
++#if !defined(__FreeBSD__)
+ #include <alloca.h>
++#endif
+ #include <string.h>
+ #include <pthread.h>
+ // OS for spinlock
diff --git a/graphics/opencolorio/pkg-descr b/graphics/opencolorio/pkg-descr
new file mode 100644
index 000000000000..71b1eeb0f613
--- /dev/null
+++ b/graphics/opencolorio/pkg-descr
@@ -0,0 +1,5 @@
+OpenColorIO (OCIO) is a complete color management solution geared
+towards motion picture production with an emphasis on visual effects
+and computer animation.
+
+WWW: http://www.opencolorio.org
diff --git a/graphics/opencolorio/pkg-plist b/graphics/opencolorio/pkg-plist
new file mode 100644
index 000000000000..e5e478855971
--- /dev/null
+++ b/graphics/opencolorio/pkg-plist
@@ -0,0 +1,18 @@
+%%CLIAPPS%%bin/ociobakelut
+%%CLIAPPS%%bin/ociocheck
+%%CLIAPPS%%bin/ocioconvert
+%%CLIAPPS%%bin/ociodisplay
+%%CLIAPPS%%bin/ociolutimage
+include/OpenColorIO/OpenColorTypes.h
+include/OpenColorIO/OpenColorTransforms.h
+include/OpenColorIO/OpenColorABI.h
+include/OpenColorIO/OpenColorIO.h
+lib/libOpenColorIO.a
+lib/libOpenColorIO.so
+lib/libOpenColorIO.so.1
+lib/libOpenColorIO.so.1.0.7
+libdata/pkgconfig/OpenColorIO.pc
+share/ocio/setup_ocio.sh
+@dirrm include/OpenColorIO
+@dirrmtry libdata/pkgconfig
+@dirrm share/ocio