aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-10 11:07:56 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-10 11:07:56 +0800
commitd5ea13239893cbd23467a8c19fd466bfc5810def (patch)
treefb8ba382167f3ffef0af55cea90ce79d03af3b3d /graphics
parent19b868c745a2251b97441f45e924d1e3606f33e3 (diff)
downloadfreebsd-ports-gnome-d5ea13239893cbd23467a8c19fd466bfc5810def.tar.gz
freebsd-ports-gnome-d5ea13239893cbd23467a8c19fd466bfc5810def.tar.zst
freebsd-ports-gnome-d5ea13239893cbd23467a8c19fd466bfc5810def.zip
add GOPchop 0.6
MPEG2 GOP-accurate editor
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gopchop/Makefile35
-rw-r--r--graphics/gopchop/distinfo1
-rw-r--r--graphics/gopchop/pkg-comment1
-rw-r--r--graphics/gopchop/pkg-descr6
-rw-r--r--graphics/gopchop/pkg-plist6
6 files changed, 50 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index ee17c91077c6..051a665e5f86 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -99,6 +99,7 @@
SUBDIR += gnofract4d
SUBDIR += gnomecanvas
SUBDIR += gnomeiconedit
+ SUBDIR += gopchop
SUBDIR += gozer
SUBDIR += gpaint
SUBDIR += gphoto2
diff --git a/graphics/gopchop/Makefile b/graphics/gopchop/Makefile
new file mode 100644
index 000000000000..f7b953c445b4
--- /dev/null
+++ b/graphics/gopchop/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: GOPchop
+# Date created: Apr 24, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gopchop
+PORTVERSION= 0.6
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://outflux.net/unix/software/GOPchop/download/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= GOPchop-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libvo.a:${PORTSDIR}/graphics/libmpeg2
+LIB_DEPENDS= mpeg2:${PORTSDIR}/graphics/libmpeg2 \
+ SDL-1.1:${PORTSDIR}/devel/sdl12 \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -D__GNU_LIBRARY__" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lSDL-1.1 -lgnugetopt"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-lSDL|-lSDL-1.1|g" \
+ -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|-lglib||g" ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/gopchop/distinfo b/graphics/gopchop/distinfo
new file mode 100644
index 000000000000..66125447f3c7
--- /dev/null
+++ b/graphics/gopchop/distinfo
@@ -0,0 +1 @@
+MD5 (GOPchop-0.6.tar.gz) = dbd1cf67038db966f7be6362845130f6
diff --git a/graphics/gopchop/pkg-comment b/graphics/gopchop/pkg-comment
new file mode 100644
index 000000000000..15ed1fdec481
--- /dev/null
+++ b/graphics/gopchop/pkg-comment
@@ -0,0 +1 @@
+MPEG2 GOP-accurate editor
diff --git a/graphics/gopchop/pkg-descr b/graphics/gopchop/pkg-descr
new file mode 100644
index 000000000000..aadb7cfd44f3
--- /dev/null
+++ b/graphics/gopchop/pkg-descr
@@ -0,0 +1,6 @@
+This tool is used for people wanting to take sections out of MPEG2-PS files
+without re-encoding the resulting frames. The idea is to write specific
+"Group of Pictures" (GOP) sections to a new MPEG2-PS file. These GOPs will
+decode correctly (in theory), and the gaps won't be noticed.
+
+WWW: http://gopchop.sourceforge.net/
diff --git a/graphics/gopchop/pkg-plist b/graphics/gopchop/pkg-plist
new file mode 100644
index 000000000000..8565ba8f893c
--- /dev/null
+++ b/graphics/gopchop/pkg-plist
@@ -0,0 +1,6 @@
+bin/GOPchop
+bin/mpegcat
+share/GOPchop/pixmaps/about.xpm
+share/GOPchop/pixmaps/error.xpm
+@dirrm share/GOPchop/pixmaps
+@dirrm share/GOPchop