aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-07-25 04:14:36 +0800
committertobik <tobik@FreeBSD.org>2018-07-25 04:14:36 +0800
commitd8cd8c7fe16bd1bba35609fb27692c69d875c228 (patch)
tree5b30f7fc27ac3052acd0973c8bba6882c9cfab44 /graphics
parentd6475929940d08d400bc163be8ed252fb6f10ba1 (diff)
downloadfreebsd-ports-gnome-d8cd8c7fe16bd1bba35609fb27692c69d875c228.tar.gz
freebsd-ports-gnome-d8cd8c7fe16bd1bba35609fb27692c69d875c228.tar.zst
freebsd-ports-gnome-d8cd8c7fe16bd1bba35609fb27692c69d875c228.zip
graphics/cuneiform: Slap on a band-aid and fix build with Clang 6
- Code base compiles under USE_CXXSTD=gnu++98 - Use options helpers - Fix no-op IMAGEMAGICK option; the patch to disable it no longer did anything. With ImageMagick installed in the build environment ImageMagick support was enabled regardless of option state - Deprecate. It's unmaintained upstream and the build problems will likely get worse over time - Take maintainership http://beefy11.nyi.freebsd.org/data/head-i386-default/p475217_s336659/logs/cuneiform-1.1.0_4.log PR: 216197
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cuneiform/Makefile23
1 files changed, 8 insertions, 15 deletions
diff --git a/graphics/cuneiform/Makefile b/graphics/cuneiform/Makefile
index 32061ed69e6f..995fa23efd81 100644
--- a/graphics/cuneiform/Makefile
+++ b/graphics/cuneiform/Makefile
@@ -3,41 +3,34 @@
PORTNAME= cuneiform
PORTVERSION= 1.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= http://launchpadlibrarian.net/69906918/
DISTNAME= ${PORTNAME}-linux-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tobik@FreeBSD.org
COMMENT= OCR system developed and open sourced by Cognitive technologies
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/cuneiform_src/Kern/license.txt
-ONLY_FOR_ARCHS= i386 amd64
+DEPRECATED= Unmaintained upstream
+EXPIRATION_DATE= 2018-12-15
+ONLY_FOR_ARCHS= amd64 i386
USES= cmake:outsource tar:bzip2
+USE_CXXSTD= gnu++98
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-CFLAGS+= -I${LOCALBASE}/include
-
OPTIONS_DEFINE= IMAGEMAGICK
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIMAGEMAGICK}
-LIB_DEPENDS+= libMagickWand-6.so:graphics/ImageMagick
-.endif
+IMAGEMAGICK_LIB_DEPENDS= libMagick++-6.so:graphics/ImageMagick
+IMAGEMAGICK_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_ImageMagick
post-patch:
${MV} ${WRKSRC}/cuneiform_src/Kern/hhh/tigerh/h/strings.h \
${WRKSRC}/cuneiform_src/Kern/hhh/tigerh/h/cf_strings.h
@${REINPLACE_CMD} -e 's:\[(uchar):\[(uchar)L:' \
${WRKSRC}/cuneiform_src/Kern/leo/src/leo_dll.c
-.if ! ${PORT_OPTIONS:MIMAGEMAGICK}
- @${REINPLACE_CMD} -e '/pkg_check_modules.*ImageMagick/ d' \
- ${WRKSRC}/cuneiform_src/Kern/CMakeLists.txt
-.endif
.include <bsd.port.mk>