aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-08-20 17:48:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-08-20 17:48:39 +0800
commitdfc5c78aeb12173dec7c045af80fd68906d8d112 (patch)
tree3303742826c48025ede53d6a705b0fc0c908cfd0 /graphics
parent794485cc042ed4377176f75bc3ed278aa90b663e (diff)
downloadfreebsd-ports-gnome-dfc5c78aeb12173dec7c045af80fd68906d8d112.tar.gz
freebsd-ports-gnome-dfc5c78aeb12173dec7c045af80fd68906d8d112.tar.zst
freebsd-ports-gnome-dfc5c78aeb12173dec7c045af80fd68906d8d112.zip
Update graphics/openjpeg to 2.2.0
Changes: https://github.com/uclouvain/openjpeg/blob/master/CHANGELOG.md PR: 221478 Exp-run by: antoine
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gstreamer1-plugins-openjpeg/Makefile2
-rw-r--r--graphics/gstreamer1-plugins-openjpeg/files/patch-openjpeg22157
-rw-r--r--graphics/mupdf/files/patch-source__fitz__load-jpx.c2
-rw-r--r--graphics/openjpeg/Makefile5
-rw-r--r--graphics/openjpeg/distinfo6
-rw-r--r--graphics/openjpeg/pkg-plist3
6 files changed, 167 insertions, 8 deletions
diff --git a/graphics/gstreamer1-plugins-openjpeg/Makefile b/graphics/gstreamer1-plugins-openjpeg/Makefile
index cb4eb2d56c4f..c69b6cf2c50b 100644
--- a/graphics/gstreamer1-plugins-openjpeg/Makefile
+++ b/graphics/gstreamer1-plugins-openjpeg/Makefile
@@ -10,4 +10,6 @@ DIST= bad
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+EXTRA_PATCHES= ${.CURDIR}/files/patch-openjpeg22
+
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-openjpeg/files/patch-openjpeg22 b/graphics/gstreamer1-plugins-openjpeg/files/patch-openjpeg22
new file mode 100644
index 000000000000..203971ff9a38
--- /dev/null
+++ b/graphics/gstreamer1-plugins-openjpeg/files/patch-openjpeg22
@@ -0,0 +1,157 @@
+--- config.h.in.orig 2017-07-14 08:21:19 UTC
++++ config.h.in
+@@ -456,6 +456,9 @@
+ /* Define if OpenJPEG 2.1 is used */
+ #undef HAVE_OPENJPEG_2_1
+
++/* Define if OpenJPEG 2.2 is used */
++#undef HAVE_OPENJPEG_2_2
++
+ /* Define to enable openni2 library (used by openni2). */
+ #undef HAVE_OPENNI2
+
+--- configure.orig 2017-07-14 08:21:19 UTC
++++ configure
+@@ -773,6 +773,8 @@ USE_OPENJPEG_TRUE
+ HAVE_OPENJPEG
+ OPENJPEG_2_1_LIBS
+ OPENJPEG_2_1_CFLAGS
++OPENJPEG_2_2_LIBS
++OPENJPEG_2_2_CFLAGS
+ OPENJPEG_LIBS
+ OPENJPEG_CFLAGS
+ USE_OPENH264_FALSE
+@@ -2039,6 +2041,8 @@ OPENJPEG_CFLAGS
+ OPENJPEG_LIBS
+ OPENJPEG_2_1_CFLAGS
+ OPENJPEG_2_1_LIBS
++OPENJPEG_2_2_CFLAGS
++OPENJPEG_2_2_LIBS
+ OPENNI2_CFLAGS
+ OPENNI2_LIBS
+ OPUS_CFLAGS
+@@ -48827,10 +48831,110 @@ $as_echo "yes" >&6; }
+ fi
+
+
+- if test x"$HAVE_OPENJPEG" = x"yes"; then
++ if test x"$HAVE_OPENJPEG_2_1" = x"yes"; then
+
+ $as_echo "#define HAVE_OPENJPEG_2_1 1" >>confdefs.h
+
++
++ which="libopenjp2 >= 2.2"
++ required="no"
++
++
++pkg_failed=no
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for OPENJPEG_2_2" >&5
++$as_echo_n "checking for OPENJPEG_2_2... " >&6; }
++
++if test -n "$PKG_CONFIG"; then
++ if test -n "$OPENJPEG_2_2_CFLAGS"; then
++ pkg_cv_OPENJPEG_2_2_CFLAGS="$OPENJPEG_2_2_CFLAGS"
++ else
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\$which\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "$which") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_OPENJPEG_2_2_CFLAGS=`$PKG_CONFIG --cflags "$which" 2>/dev/null`
++else
++ pkg_failed=yes
++fi
++ fi
++else
++ pkg_failed=untried
++fi
++if test -n "$PKG_CONFIG"; then
++ if test -n "$OPENJPEG_2_2_LIBS"; then
++ pkg_cv_OPENJPEG_2_2_LIBS="$OPENJPEG_2_2_LIBS"
++ else
++ if test -n "$PKG_CONFIG" && \
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"\$which\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "$which") 2>&5
++ ac_status=$?
++ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++ test $ac_status = 0; }; then
++ pkg_cv_OPENJPEG_2_2_LIBS=`$PKG_CONFIG --libs "$which" 2>/dev/null`
++else
++ pkg_failed=yes
++fi
++ fi
++else
++ pkg_failed=untried
++fi
++
++
++
++if test $pkg_failed = yes; then
++
++if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
++ _pkg_short_errors_supported=yes
++else
++ _pkg_short_errors_supported=no
++fi
++ if test $_pkg_short_errors_supported = yes; then
++ OPENJPEG_2_2_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "$which"`
++ else
++ OPENJPEG_2_2_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$which"`
++ fi
++ # Put the nasty error message in config.log where it belongs
++ echo "$OPENJPEG_2_2_PKG_ERRORS" >&5
++
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++
++ HAVE_OPENJPEG_2_2="no"
++ if test "x$required" = "xyes"; then
++ as_fn_error $? "$OPENJPEG_2_2_PKG_ERRORS" "$LINENO" 5
++ else
++ { $as_echo "$as_me:${as_lineno-$LINENO}: $OPENJPEG_2_2_PKG_ERRORS" >&5
++$as_echo "$as_me: $OPENJPEG_2_2_PKG_ERRORS" >&6;}
++ fi
++
++elif test $pkg_failed = untried; then
++
++ HAVE_OPENJPEG_2_2="no"
++ if test "x$required" = "xyes"; then
++ as_fn_error $? "$OPENJPEG_2_2_PKG_ERRORS" "$LINENO" 5
++ else
++ { $as_echo "$as_me:${as_lineno-$LINENO}: $OPENJPEG_2_2_PKG_ERRORS" >&5
++$as_echo "$as_me: $OPENJPEG_2_2_PKG_ERRORS" >&6;}
++ fi
++
++else
++ OPENJPEG_2_2_CFLAGS=$pkg_cv_OPENJPEG_2_2_CFLAGS
++ OPENJPEG_2_2_LIBS=$pkg_cv_OPENJPEG_2_2_LIBS
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++
++ HAVE_OPENJPEG_2_2="yes"
++
++fi
++
++
++ if test x"$HAVE_OPENJPEG_2_2" = x"yes"; then
++
++$as_echo "#define HAVE_OPENJPEG_2_2 1" >>confdefs.h
++
++ fi
+ fi
+ else
+ # Fallback to v1.5
+--- ext/openjpeg/gstopenjpeg.h.orig 2017-05-15 15:46:30 UTC
++++ ext/openjpeg/gstopenjpeg.h
+@@ -38,7 +38,9 @@
+ #define OPJ_CPRL CPRL
+ #else
+ #include <stdio.h>
+-# ifdef HAVE_OPENJPEG_2_1
++# if defined(HAVE_OPENJPEG_2_2)
++# include <openjpeg-2.2/openjpeg.h>
++# elif defined(HAVE_OPENJPEG_2_1)
+ # include <openjpeg-2.1/openjpeg.h>
+ # else
+ # include <openjpeg-2.0/openjpeg.h>
diff --git a/graphics/mupdf/files/patch-source__fitz__load-jpx.c b/graphics/mupdf/files/patch-source__fitz__load-jpx.c
index 34fe65d83ebc..2b9bc9de1175 100644
--- a/graphics/mupdf/files/patch-source__fitz__load-jpx.c
+++ b/graphics/mupdf/files/patch-source__fitz__load-jpx.c
@@ -16,7 +16,7 @@
#define USE_JPIP
-#include <openjpeg.h>
-+#include <openjpeg-2.1/openjpeg.h>
++#include <openjpeg-2.2/openjpeg.h>
struct fz_jpxd_s
{
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index fce36d5499a3..307ee2822e97 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= openjpeg
-PORTVERSION= 2.1.2
+PORTVERSION= 2.2.0
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= sunpoet@FreeBSD.org
@@ -21,7 +20,7 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
USE_LDCONFIG= yes
USES= cmake cpe pkgconfig
-PLIST_SUB= VER=${PORTVERSION:R}
+PLIST_SUB= PORTVERSION=${PORTVERSION} VER=${PORTVERSION:R}
GH_ACCOUNT= uclouvain
USE_GITHUB= yes
diff --git a/graphics/openjpeg/distinfo b/graphics/openjpeg/distinfo
index e99d5d0a0208..f500e715785c 100644
--- a/graphics/openjpeg/distinfo
+++ b/graphics/openjpeg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1475154150
-SHA256 (uclouvain-openjpeg-v2.1.2_GH0.tar.gz) = 4ce77b6ef538ef090d9bde1d5eeff8b3069ab56c4906f083475517c2c023dfa7
-SIZE (uclouvain-openjpeg-v2.1.2_GH0.tar.gz) = 1987071
+TIMESTAMP = 1502573051
+SHA256 (uclouvain-openjpeg-v2.2.0_GH0.tar.gz) = 6fddbce5a618e910e03ad00d66e7fcd09cc6ee307ce69932666d54c73b7c6e7b
+SIZE (uclouvain-openjpeg-v2.2.0_GH0.tar.gz) = 2847582
diff --git a/graphics/openjpeg/pkg-plist b/graphics/openjpeg/pkg-plist
index c18fede3dbaa..0c05f9efebb1 100644
--- a/graphics/openjpeg/pkg-plist
+++ b/graphics/openjpeg/pkg-plist
@@ -4,8 +4,9 @@ bin/opj_dump
include/openjpeg-%%VER%%/openjpeg.h
include/openjpeg-%%VER%%/opj_config.h
include/openjpeg-%%VER%%/opj_stdint.h
+lib/libopenjp2.a
lib/libopenjp2.so
-lib/libopenjp2.so.%%VER%%.2
+lib/libopenjp2.so.%%PORTVERSION%%
lib/libopenjp2.so.7
lib/openjpeg-%%VER%%/OpenJPEGConfig.cmake
lib/openjpeg-%%VER%%/OpenJPEGTargets-%%CMAKE_BUILD_TYPE%%.cmake