aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-02-13 08:16:29 +0800
committerpav <pav@FreeBSD.org>2007-02-13 08:16:29 +0800
commite03c6d722481f6f7ccee2da2c2def819dad553a5 (patch)
tree42c24cd1a7707170111dcbac87514de8975bf4ee /graphics
parentcf9bf9c623b407a743c1d6efdd81a619a5c0e2c9 (diff)
downloadfreebsd-ports-gnome-e03c6d722481f6f7ccee2da2c2def819dad553a5.tar.gz
freebsd-ports-gnome-e03c6d722481f6f7ccee2da2c2def819dad553a5.tar.zst
freebsd-ports-gnome-e03c6d722481f6f7ccee2da2c2def819dad553a5.zip
- Remove QTDIR from CONFIGURE_ENV, it's in there already thanks to framework
Submitted by: rafan Tested on: pointyhat
Diffstat (limited to 'graphics')
-rw-r--r--graphics/amanith/Makefile2
-rw-r--r--graphics/evolvotron/Makefile2
-rw-r--r--graphics/ipe/Makefile2
-rw-r--r--graphics/landscape/Makefile2
-rw-r--r--graphics/moth/Makefile2
-rw-r--r--graphics/poppler/Makefile2
-rw-r--r--graphics/qgis/Makefile2
-rw-r--r--graphics/qglviewer/Makefile1
-rw-r--r--graphics/view3ds/Makefile1
9 files changed, 7 insertions, 9 deletions
diff --git a/graphics/amanith/Makefile b/graphics/amanith/Makefile
index ec7023ac7bdb..9a4ac523f3af 100644
--- a/graphics/amanith/Makefile
+++ b/graphics/amanith/Makefile
@@ -29,7 +29,7 @@ USE_GMAKE= yes
USE_DOS2UNIX= yes
USE_LDCONFIG= yes
-MAKE_ENV= QTDIR="${LOCALBASE}" \
+MAKE_ENV= QTDIR="${QT_PREFIX}" \
QMAKESPEC="${QMAKESPEC}" \
AMANITHDIR="${AMANITHDIR}"
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 5a276bc6c0fb..803367d4f2ee 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -22,7 +22,7 @@ USE_PYTHON= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-MAKE_ENV= QTDIR=${X11BASE} MOC=${MOC}
+MAKE_ENV= QTDIR=${QT_PREFIX} MOC=${MOC}
.include <bsd.port.pre.mk>
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 2d4b46593b83..9a548064f43f 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -37,7 +37,7 @@ USE_GCC= 3.4
BROKEN= Does not compile on 4.x
.endif
-QTDIR?= ${X11BASE}
+QTDIR?= ${QT_PREFIX}
QMAKE?= ${LOCALBASE}/bin/qmake
pre-fetch:
diff --git a/graphics/landscape/Makefile b/graphics/landscape/Makefile
index 9f449a4d5490..d473c5731c88 100644
--- a/graphics/landscape/Makefile
+++ b/graphics/landscape/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
PLIST_FILES= bin/landscape
USE_KDELIBS_VER= 3
-QTDIR?= ${X11BASE}
+QTDIR?= ${QT_PREFIX}
MAKE_ENV= QTDIR="${QTDIR}"
pre-build:
diff --git a/graphics/moth/Makefile b/graphics/moth/Makefile
index 507b62192e97..2aa768cd3fd8 100644
--- a/graphics/moth/Makefile
+++ b/graphics/moth/Makefile
@@ -22,7 +22,7 @@ USE_QT_VER= 3
USE_GL= yes
USE_X_PREFIX= yes
MAKE_ARGS= CC="${CXX}" XLIBDIR="${X11BASE}/lib" MOC="${MOC}" \
- CFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS}" QTDIR="${X11BASE}" \
+ CFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS}" QTDIR="${QT_PREFIX}" \
GLINCLUDEDIR="${X11BASE}/include" \
MOTH_INCLUDES="${WRKSRC_LIBMOTH}/include" \
MOTH_LIBRARIES="${WRKSRC_LIBMOTH}/lib"
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index 20efa1417c6e..f2c8df61d140 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -70,7 +70,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/qt/include|${X11BASE}/include|; \
s|/usr/local/qt/lib|${X11BASE}/lib|' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|$$QTDIR|${X11BASE}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$QTDIR|${QT_PREFIX}|' ${WRKSRC}/configure
.endif
post-install:
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 8db38b09180a..a4f54952f934 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -42,7 +42,7 @@ BROKEN= Does not build on FreeBSD versions prior to 5
.endif
.if !defined (QTDIR)
-QTDIR= ${X11BASE}
+QTDIR= ${QT_PREFIX}
.endif
.if !defined (GRASS_INST_DIR)
diff --git a/graphics/qglviewer/Makefile b/graphics/qglviewer/Makefile
index 58bab7cb2137..f971cc8705bf 100644
--- a/graphics/qglviewer/Makefile
+++ b/graphics/qglviewer/Makefile
@@ -20,7 +20,6 @@ USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= QTDIR="${X11BASE}"
USE_LDCONFIG= yes
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/graphics/view3ds/Makefile b/graphics/view3ds/Makefile
index 0d27ae35b2d8..12804cc80261 100644
--- a/graphics/view3ds/Makefile
+++ b/graphics/view3ds/Makefile
@@ -29,7 +29,6 @@ USE_X_PREFIX= yes
USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"